Bug 252851 - Unpacking Maven index stalls
Unpacking Maven index stalls
Status: RESOLVED DUPLICATE of bug 239915
Product: projects
Classification: Unclassified
Component: Maven
8.0.2
PC Windows XP
: P2 (vote)
: TBD
Assigned To: Tomas Stupka
issues@projects
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2015-06-06 20:54 UTC by bht
Modified: 2015-06-08 09:08 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments
Project (2.62 KB, application/zip)
2015-06-06 20:54 UTC, bht
Details
Thread dump (24.60 KB, application/octet-stream)
2015-06-06 20:55 UTC, bht
Details
log file (118.92 KB, text/plain)
2015-06-06 20:56 UTC, bht
Details

Note You need to log in before you can comment on or make changes to this bug.
Description bht 2015-06-06 20:54:05 UTC
Created attachment 154084 [details]
Project

With a simple maven project having a custom repository that I hadn't used before.

Hung here for approximately an hour:
Unpacking index for sonatype-staging io.vertx:mod-mongo-persistor

I am adding the project, log file and thread dump.
Comment 1 bht 2015-06-06 20:55:33 UTC
Created attachment 154085 [details]
Thread dump
Comment 2 bht 2015-06-06 20:56:14 UTC
Created attachment 154086 [details]
log file
Comment 3 Tomas Stupka 2015-06-08 09:08:40 UTC
in scope of issue #239915 there were made some significant improvements made to maven indexing

feel to reopen this issue in case you are encountering the same problems as described with a current dev build, 
also please provide a profiler snapshots 

thanks

*** This bug has been marked as a duplicate of bug 239915 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo