Bug 25202 - Stack trace printed from scripted expression -> deadlock
Stack trace printed from scripted expression -> deadlock
Status: RESOLVED FIXED
Product: obsolete
Classification: Unclassified
Component: languages
3.x
PC Linux
: P2 (vote)
: TBD
Assigned To: issues@ide
issues@obsolete
:
: 22871 (view as bug list)
Depends on: 25180
Blocks:
  Show dependency treegraph
 
Reported: 2002-06-26 17:01 UTC by Jesse Glick
Modified: 2008-08-01 15:47 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments
Thread dump (11.84 KB, text/plain)
2002-06-26 17:01 UTC, Jesse Glick
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Jesse Glick 2002-06-26 17:01:04 UTC
[dev jun 26] I opened scripting console. Typed

Class.forName("java.lang.String")

selected it and pressed Alt-V to eval. Worked
fine. Then deleted result, edited to read

Class.forName("java.lang.String[]")

(which I believe is incorrect syntax), selected
it, pressed Alt-V, and NB deadlocked immediately.

Thread dump attached. Looks like printing some
stack trace (CNFE I presume) caused it.
EvaluateConsole is at fault IMHO for running in
the AWT event thread;
evaluateButtonActionPerformed should use e.g.
RP.getDefault().post(...).
Comment 1 Jesse Glick 2002-06-26 17:01:55 UTC
Created attachment 6447 [details]
Thread dump
Comment 2 Milos Kleint 2002-06-27 09:16:53 UTC
fixed in trunk.
Comment 3 Milos Kleint 2002-06-27 09:22:10 UTC
*** Issue 22871 has been marked as a duplicate of this issue. ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo