Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 251693 - NPE when taking a Thread Dump
NPE when taking a Thread Dump
Status: RESOLVED DUPLICATE of bug 248855
Product: profiler
Classification: Unclassified
Component: Base
8.1
PC Windows 7
: P3 (vote)
: TBD
Assigned To: issues@profiler
issues@profiler
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2015-04-07 09:37 UTC by stwr
Modified: 2015-04-07 11:04 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments
Copy of messages.log (66.44 KB, text/plain)
2015-04-07 09:37 UTC, stwr
Details

Note You need to log in before you can comment on or make changes to this bug.
Description stwr 2015-04-07 09:37:22 UTC
Created attachment 153074 [details]
Copy of messages.log

Product Version: NetBeans IDE Dev (Build 201504020001)
Java: 1.8.0_31; Java HotSpot(TM) 64-Bit Server VM 25.31-b07
Runtime: Java(TM) SE Runtime Environment 1.8.0_31-b13
System: Windows 7 version 6.1 running on amd64; Cp1250; en_US (nb)
User directory: C:\Users\cendrowiczm\AppData\Roaming\NetBeans\dev
Cache directory: C:\Users\cendrowiczm\AppData\Local\NetBeans\Cache\dev

Use Case:

1. Run some class (e.g. MemoryLeakOrNot?|Example4|main)
2. Attach profiler to it (Profile External Process)
3. Execute the 'Thread Dump' action

Following exception is thrown:

java.lang.NullPointerException: Method name is null
	at java.util.Objects.requireNonNull(Objects.java:228)
	at java.lang.StackTraceElement.<init>(StackTraceElement.java:72)
	at sun.management.StackTraceElementCompositeData.from(StackTraceElementCompositeData.java:55)
	at sun.management.ThreadInfoCompositeData.stackTrace(ThreadInfoCompositeData.java:317)
	at java.lang.management.ThreadInfo.<init>(ThreadInfo.java:277)
	at java.lang.management.ThreadInfo.from(ThreadInfo.java:794)
	at org.netbeans.lib.profiler.results.threads.ThreadDump.getThreads(ThreadDump.java:80)
	at org.netbeans.modules.profiler.ThreadDumpWindow.printThreads(ThreadDumpWindow.java:131)
	at org.netbeans.modules.profiler.ThreadDumpWindow.<init>(ThreadDumpWindow.java:99)
	at org.netbeans.modules.profiler.actions.TakeThreadDumpAction$1.done(TakeThreadDumpAction.java:134)
	at javax.swing.SwingWorker$5.run(SwingWorker.java:737)
	at javax.swing.SwingWorker$DoSubmitAccumulativeRunnable.run(SwingWorker.java:832)
	at sun.swing.AccumulativeRunnable.run(AccumulativeRunnable.java:112)
	at javax.swing.SwingWorker$DoSubmitAccumulativeRunnable.actionPerformed(SwingWorker.java:842)
	at javax.swing.Timer.fireActionPerformed(Timer.java:313)
	at javax.swing.Timer$DoPostEvent.run(Timer.java:245)
	at java.awt.event.InvocationEvent.dispatch(InvocationEvent.java:311)
	at java.awt.EventQueue.dispatchEventImpl(EventQueue.java:749)
	at java.awt.EventQueue.access$500(EventQueue.java:97)
	at java.awt.EventQueue$3.run(EventQueue.java:702)
	at java.awt.EventQueue$3.run(EventQueue.java:696)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.security.ProtectionDomain$1.doIntersectionPrivilege(ProtectionDomain.java:75)
	at java.awt.EventQueue.dispatchEvent(EventQueue.java:719)
	at org.netbeans.core.TimableEventQueue.dispatchEvent(TimableEventQueue.java:159)
[catch] at java.awt.EventDispatchThread.pumpOneEventForFilters(EventDispatchThread.java:201)
	at java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:116)
	at java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:105)
	at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:101)
	at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:93)
	at java.awt.EventDispatchThread.run(EventDispatchThread.java:82)
Comment 1 Tomas Hurka 2015-04-07 11:04:22 UTC

*** This bug has been marked as a duplicate of bug 248855 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo