Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 251268 - Clean And Build not enabled
Clean And Build not enabled
Status: RESOLVED DUPLICATE of bug 242261
Product: projects
Classification: Unclassified
Component: Generic Infrastructure
8.0.2
PC Windows 7
: P3 (vote)
: TBD
Assigned To: Tomas Stupka
issues@projects
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2015-03-18 19:37 UTC by henri127
Modified: 2015-06-03 14:26 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments
messages.log (104.35 KB, application/octet-stream)
2015-03-18 19:39 UTC, henri127
Details

Note You need to log in before you can comment on or make changes to this bug.
Description henri127 2015-03-18 19:37:16 UTC
Product Version = NetBeans IDE 8.0.2 (Build 201411181905)
Operating System = Windows 7 version 6.1 running on amd64
Java; VM; Vendor = 1.8.0_20
Runtime = Java HotSpot(TM) 64-Bit Server VM 25.20-b23

see attachment for messages.log file from session
Comment 1 henri127 2015-03-18 19:39:00 UTC
Created attachment 152700 [details]
messages.log
Comment 2 CElliott 2015-03-21 13:19:50 UTC
Thinking that the problem could be due to the updates 8.0.2 downloads on installation, I uninstalled and re-installed it (the combined jdk1.7.0_75 + NetBeans 8.0.2 version from the Oracle website), but there was no change.  One of my projects that I attempted to clean, build and run will now not even run within the NetBeans IDE.  It outputs the same error message as if I ran Clean & Build.
Here are the error messages output by NetBeans when attempting clean & build under Windows 8.1:  (The program path "P:\Program Files\Java\jdk-8u31-64\bin\java" is legitimate, and if executed in a DOS prompt window, executes Java.)
ant -f E:\\Development\\Netbeans8Projects\\ForkJoinSumCalculator -Dnb.internal.action.name=clean clean
E:\Development\Netbeans8Projects\ForkJoinSumCalculator\nbproject\build-impl.xml:776: Execute failed: 
java.io.IOException: Cannot run program "P:\Program Files\Java\jdk-8u31-64\bin\java" (in directory "E:\Development\Netbeans8Projects\ForkJoinSumCalculator"): CreateProcess error=193, %1 is not a valid Win32 application
	at java.lang.ProcessBuilder.start(ProcessBuilder.java:1047)
	at java.lang.Runtime.exec(Runtime.java:617)
	at org.apache.tools.ant.taskdefs.launcher.Java13CommandLauncher.exec(Java13CommandLauncher.java:58)
	at org.apache.tools.ant.taskdefs.Execute.launch(Execute.java:428)
	at org.apache.tools.ant.taskdefs.Execute.execute(Execute.java:442)
	at org.apache.tools.ant.taskdefs.ExecTask.runExecute(ExecTask.java:628)
	at org.apache.tools.ant.taskdefs.ExecTask.runExec(ExecTask.java:669)
	at org.apache.tools.ant.taskdefs.ExecTask.execute(ExecTask.java:495)
	at org.apache.tools.ant.UnknownElement.execute(UnknownElement.java:292)
	at sun.reflect.GeneratedMethodAccessor86.invoke(Unknown Source)
	at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
	at java.lang.reflect.Method.invoke(Method.java:606)
	at org.apache.tools.ant.dispatch.DispatchUtils.execute(DispatchUtils.java:106)
	at org.apache.tools.ant.Task.perform(Task.java:348)
	at org.apache.tools.ant.Target.execute(Target.java:435)
	at org.apache.tools.ant.Target.performTasks(Target.java:456)
	at org.apache.tools.ant.Project.executeSortedTargets(Project.java:1393)
	at org.apache.tools.ant.Project.executeTarget(Project.java:1364)
	at org.apache.tools.ant.helper.DefaultExecutor.executeTargets(DefaultExecutor.java:41)
	at org.apache.tools.ant.Project.executeTargets(Project.java:1248)
	at org.apache.tools.ant.module.bridge.impl.BridgeImpl.run(BridgeImpl.java:286)
	at org.apache.tools.ant.module.run.TargetExecutor.run(TargetExecutor.java:555)
	at org.netbeans.core.execution.RunClassThread.run(RunClassThread.java:153)
Caused by: java.io.IOException: CreateProcess error=193, %1 is not a valid Win32 application
	at java.lang.ProcessImpl.create(Native Method)
	at java.lang.ProcessImpl.<init>(ProcessImpl.java:385)
	at java.lang.ProcessImpl.start(ProcessImpl.java:136)
	at java.lang.ProcessBuilder.start(ProcessBuilder.java:1028)
	... 22 more
Comment 3 Tomas Stupka 2015-06-03 14:26:37 UTC

*** This bug has been marked as a duplicate of bug 242261 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo