Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 251092 - NBI installer doesn't work on JDK9
NBI installer doesn't work on JDK9
Status: RESOLVED FIXED
Product: installer
Classification: Unclassified
Component: NBI
8.0.2
PC Unix
: P2 (vote)
: 8.1
Assigned To: Libor Fischmeistr
issues@installer
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2015-03-11 09:08 UTC by Libor Fischmeistr
Modified: 2015-03-27 03:22 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Libor Fischmeistr 2015-03-11 09:08:17 UTC
NBI installer doesn't work on JDK9 on Mac (not sure how on other platforms).
Comment 1 Libor Fischmeistr 2015-03-25 08:23:31 UTC
I can confirm the same behaviour for Linux. On Windows the installer is launched, but the JDK not found.

The reason is that the files in JDK 9 does not correspond to previous JDK versions. For example /lib/dt.jar is missing in JDK 9
Comment 2 Libor Fischmeistr 2015-03-26 10:27:55 UTC
Fixed - http://hg.netbeans.org/core-main/rev/f99407f18f80
Comment 3 Quality Engineering 2015-03-27 03:22:05 UTC
Integrated into 'main-silver', will be available in build *201503270001* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)

Changeset: http://hg.netbeans.org/main-silver/rev/f99407f18f80
User: Libor Fischmeistr <lfischmeistr@netbeans.org>
Log: #251092: NBI installer doesn't work on JDK9


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo