Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 250771 - OutOfMemoryError: Java heap space
OutOfMemoryError: Java heap space
Status: RESOLVED DUPLICATE of bug 249165
Product: web
Classification: Unclassified
Component: HTML Project
8.0
All All
: P3 (vote)
: TBD
Assigned To: Tomas Mysik
issues@web
EXCEPTIONS_REPORT
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2015-02-27 15:25 UTC by Exceptions Reporter
Modified: 2015-02-27 15:30 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments
stacktrace (2.23 KB, text/plain)
2015-02-27 15:25 UTC, Exceptions Reporter
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Exceptions Reporter 2015-02-27 15:25:15 UTC
This issue was reported manually by thurka.
It already has 1 duplicates 


Build: NetBeans IDE 8.0 (Build 201403101706)
VM: Java HotSpot(TM) Client VM, 25.20-b23, Java(TM) SE Runtime Environment, 1.8.0_20-b26
OS: Windows 7

User Comments:
GUEST: I make the tutorial in netbeans doc :
Introduction to Ajax for Java Web Applications
https://netbeans.org/kb/docs/web/ajax-quickstart.html
with glassfish 4. I started the App and then Error.
My Spec: Netbook with win 7 Starter 2 GB RAM




Stacktrace: 
java.lang.OutOfMemoryError: Java heap space
   at java.awt.image.DataBufferInt.<init>(DataBufferInt.java:75)
   at java.awt.image.Raster.createPackedRaster(Raster.java:467)
   at java.awt.image.DirectColorModel.createCompatibleWritableRaster(DirectColorModel.java:1032)
   at java.awt.image.BufferedImage.<init>(BufferedImage.java:340)
   at com.sun.java.swing.plaf.windows.XPStyle$SkinPainter.createImage(XPStyle.java:673)
   at sun.swing.CachedPainter.paint0(CachedPainter.java:139)
Comment 1 Exceptions Reporter 2015-02-27 15:25:16 UTC
Created attachment 152283 [details]
stacktrace
Comment 2 Tomas Hurka 2015-02-27 15:30:32 UTC
Retained size of java.util.ArrayList#76487 is 146,005,678 bytes. This ArrayList is contains instances of DefaultLibraryImplementation. All this created by "org.netbeans.modules.web.clientproject.api.jslibs.JavaScriptLibrarySelectionPanel"
 thread.

*** This bug has been marked as a duplicate of bug 249165 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo