Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 250621 - OutOfMemoryError: Java heap space
OutOfMemoryError: Java heap space
Status: RESOLVED DUPLICATE of bug 249165
Product: ide
Classification: Unclassified
Component: Performance
8.0
All All
: P3 (vote)
: TBD
Assigned To: Tomas Hurka
issues@performance
EXCEPTIONS_REPORT
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2015-02-23 08:40 UTC by Exceptions Reporter
Modified: 2015-02-23 08:42 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments
stacktrace (2.30 KB, text/plain)
2015-02-23 08:40 UTC, Exceptions Reporter
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Exceptions Reporter 2015-02-23 08:40:07 UTC
This issue was reported manually by thurka.
It already has 1 duplicates 


Build: NetBeans IDE 8.0.2 (Build 201411181905)
VM: Java HotSpot(TM) Client VM, 25.25-b02, Java(TM) SE Runtime Environment, 1.8.0_25-b18
OS: Windows 7

User Comments:
GUEST: update errr




Stacktrace: 
java.lang.OutOfMemoryError: Java heap space
   at java.awt.image.DataBufferInt.<init>(DataBufferInt.java:75)
   at java.awt.image.Raster.createPackedRaster(Raster.java:467)
   at java.awt.image.DirectColorModel.createCompatibleWritableRaster(DirectColorModel.java:1032)
   at java.awt.image.BufferedImage.<init>(BufferedImage.java:340)
   at com.sun.java.swing.plaf.windows.XPStyle$SkinPainter.createImage(XPStyle.java:673)
   at sun.swing.CachedPainter.paint0(CachedPainter.java:139)
Comment 1 Exceptions Reporter 2015-02-23 08:40:08 UTC
Created attachment 152150 [details]
stacktrace
Comment 2 Tomas Hurka 2015-02-23 08:42:53 UTC
Retained size of java.util.ArrayList#38878 is 233,142,876 bytes. It is used by org.netbeans.modules.web.clientproject.libraries.CDNJSLibrariesProvider.readLibraries() method.

*** This bug has been marked as a duplicate of bug 249165 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo