Bug 250213 - Exception in console: shouldn't be called in UI thread
Exception in console: shouldn't be called in UI thread
Status: VERIFIED FIXED
Product: cnd
Classification: Unclassified
Component: Code Model
8.0.2
PC Linux
: P3 (vote)
: 8.2
Assigned To: Alexander Simon
issues@cnd
82patch1-verified
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2015-02-04 14:35 UTC by petrk
Modified: 2016-12-12 09:03 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description petrk 2015-02-04 14:35:26 UTC
INFO [dlight.libs.common.logger]: Should not be called from UI thread
java.lang.Exception: Should not be called from UI thread
	at org.netbeans.modules.dlight.libs.common.DLightLibsCommonLogger.assertNonUiThread(DLightLibsCommonLogger.java:131)
	at org.netbeans.modules.dlight.libs.common.DLightLibsCommonLogger.assertNonUiThreadOnce(DLightLibsCommonLogger.java:141)
	at org.netbeans.modules.cnd.utils.CndUtils.assertNonUiThread(CndUtils.java:290)
	at org.netbeans.modules.cnd.modelutil.CsmUtilities.getModifiers(CsmUtilities.java:170)
	at org.netbeans.modules.cnd.modelutil.CsmImageLoader.getImagePath(CsmImageLoader.java:228)
	at org.netbeans.modules.cnd.modelutil.CsmImageLoader.getImagePath(CsmImageLoader.java:148)
	at org.netbeans.modules.cnd.modelutil.CsmImageLoader.getIcon(CsmImageLoader.java:120)
	at org.netbeans.modules.cnd.modelutil.OverridesPopup$Item.getIcon(OverridesPopup.java:136)
	at org.netbeans.modules.cnd.modelutil.OverridesPopup$RenderComponent.<init>(OverridesPopup.java:204)
	at org.netbeans.modules.cnd.modelutil.OverridesPopup$RendererImpl.getListCellRendererComponent(OverridesPopup.java:261)
	at javax.swing.plaf.basic.BasicListUI.updateLayoutState(BasicListUI.java:1361)
	at javax.swing.plaf.basic.BasicListUI.maybeUpdateLayoutState(BasicListUI.java:1311)
	at javax.swing.plaf.basic.BasicListUI.getPreferredSize(BasicListUI.java:578)
	at javax.swing.JComponent.getPreferredSize(JComponent.java:1660)
	at javax.swing.JList.getPreferredScrollableViewportSize(JList.java:2449)
	at javax.swing.ViewportLayout.preferredLayoutSize(ViewportLayout.java:92)
	at java.awt.Container.preferredSize(Container.java:1788)
	at java.awt.Container.getPreferredSize(Container.java:1773)
	at javax.swing.JComponent.getPreferredSize(JComponent.java:1662)
	at javax.swing.ScrollPaneLayout.preferredLayoutSize(ScrollPaneLayout.java:492)
	at java.awt.Container.preferredSize(Container.java:1788)
	at java.awt.Container.getPreferredSize(Container.java:1773)
	at javax.swing.JComponent.getPreferredSize(JComponent.java:1662)
	at java.awt.BorderLayout.preferredLayoutSize(BorderLayout.java:719)
	at java.awt.Container.preferredSize(Container.java:1788)
	at java.awt.Container.getPreferredSize(Container.java:1773)
	at javax.swing.JComponent.getPreferredSize(JComponent.java:1662)
	at java.awt.BorderLayout.preferredLayoutSize(BorderLayout.java:719)
	at java.awt.Container.preferredSize(Container.java:1788)
	at java.awt.Container.getPreferredSize(Container.java:1773)
	at javax.swing.JComponent.getPreferredSize(JComponent.java:1662)
	at javax.swing.JRootPane$RootLayout.preferredLayoutSize(JRootPane.java:917)
	at java.awt.Container.preferredSize(Container.java:1788)
	at java.awt.Container.getPreferredSize(Container.java:1773)
	at javax.swing.JComponent.getPreferredSize(JComponent.java:1662)
	at java.awt.BorderLayout.preferredLayoutSize(BorderLayout.java:719)
	at java.awt.Container.preferredSize(Container.java:1788)
	at java.awt.Container.getPreferredSize(Container.java:1773)
	at java.awt.Window.pack(Window.java:809)
	at org.netbeans.modules.cnd.utils.ui.PopupUtil.resizePopup(PopupUtil.java:150)
	at org.netbeans.modules.cnd.utils.ui.PopupUtil.showPopup(PopupUtil.java:119)
	at org.netbeans.modules.cnd.navigation.overrides.BaseAnnotation.performGoToAction(BaseAnnotation.java:503)
	at org.netbeans.modules.cnd.navigation.overrides.BaseAnnotation.mouseClicked(BaseAnnotation.java:473)
	at org.netbeans.modules.cnd.navigation.overrides.OverrideAnnotationAction.invokeDefaultAction(OverrideAnnotationAction.java:164)
	at org.netbeans.modules.cnd.navigation.overrides.OverrideAnnotationAction.actionPerformed(OverrideAnnotationAction.java:102)
	at org.netbeans.editor.GlyphGutter$GutterMouseListener.mouseClicked(GlyphGutter.java:961)
	at java.awt.AWTEventMulticaster.mouseClicked(AWTEventMulticaster.java:269)
	at java.awt.Component.processMouseEvent(Component.java:6508)
	at javax.swing.JComponent.processMouseEvent(JComponent.java:3320)
	at java.awt.Component.processEvent(Component.java:6270)
	at java.awt.Container.processEvent(Container.java:2229)
	at java.awt.Component.dispatchEventImpl(Component.java:4861)
	at java.awt.Container.dispatchEventImpl(Container.java:2287)
	at java.awt.Component.dispatchEvent(Component.java:4687)
	at java.awt.LightweightDispatcher.retargetMouseEvent(Container.java:4832)
	at java.awt.LightweightDispatcher.processMouseEvent(Container.java:4501)
	at java.awt.LightweightDispatcher.dispatchEvent(Container.java:4422)
	at java.awt.Container.dispatchEventImpl(Container.java:2273)
	at java.awt.Window.dispatchEventImpl(Window.java:2719)
	at java.awt.Component.dispatchEvent(Component.java:4687)
	at java.awt.EventQueue.dispatchEventImpl(EventQueue.java:735)
	at java.awt.EventQueue.access$200(EventQueue.java:103)
	at java.awt.EventQueue$3.run(EventQueue.java:694)
	at java.awt.EventQueue$3.run(EventQueue.java:692)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.security.ProtectionDomain$1.doIntersectionPrivilege(ProtectionDomain.java:76)
	at java.security.ProtectionDomain$1.doIntersectionPrivilege(ProtectionDomain.java:87)
	at java.awt.EventQueue$4.run(EventQueue.java:708)
	at java.awt.EventQueue$4.run(EventQueue.java:706)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.security.ProtectionDomain$1.doIntersectionPrivilege(ProtectionDomain.java:76)
	at java.awt.EventQueue.dispatchEvent(EventQueue.java:705)
	at org.netbeans.core.TimableEventQueue.dispatchEvent(TimableEventQueue.java:159)
	at java.awt.EventDispatchThread.pumpOneEventForFilters(EventDispatchThread.java:242)
	at java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:161)
	at java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:150)
	at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:146)
	at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:138)
	at java.awt.EventDispatchThread.run(EventDispatchThread.java:91)
Comment 1 Alexander Simon 2016-11-11 12:36:27 UTC
fixed in enum, branch release82, change set 0c188c549478
Comment 2 Quality Engineering 2016-11-16 02:51:09 UTC
Integrated into 'main-silver', will be available in build *201611160001* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)

Changeset: http://hg.netbeans.org/main-silver/rev/49daff19c86f
User: Alexander Simon <alexvsimon@netbeans.org>
Log: fixed Bug #250213 Exception in console: shouldn't be called in UI thread
- there is no proof of slowness in change set that introduced a check.
- remove the check as wrong.
(transplanted from 0c188c54947851fff705a3f81af29167392d1b36)
Comment 3 soldatov 2016-12-12 09:03:37 UTC
I can't reproduce this random exception in internal NetBeans 8,2 patch 1 build.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo