Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 250158 - Prevent Maven indexing from choking the HDD
Prevent Maven indexing from choking the HDD
Status: RESOLVED DUPLICATE of bug 239915
Product: projects
Classification: Unclassified
Component: Maven
8.0.2
PC Windows 7
: P3 (vote)
: TBD
Assigned To: Tomas Stupka
issues@projects
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2015-02-02 11:03 UTC by terje7601
Modified: 2015-05-27 14:55 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description terje7601 2015-02-02 11:03:52 UTC
As already hinted at in issue 225678, Maven indexing makes classical hard disk drives choke. It slows down the whole PC, to the extent of rendering it unusable.
Comment 2 Tomas Stupka 2015-05-27 14:55:08 UTC
in scope of issue #239915 there were made some significant improvements to maven indexing

otherwise please provide more info about:
- your build 
- the index you are trying to process - origin, size, etc.
- some profiler snapshots would be also of use

thanks

*** This bug has been marked as a duplicate of bug 239915 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo