Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 248958 - text/ng-template script type for AngularJS templateCache does not recognize content as html
text/ng-template script type for AngularJS templateCache does not recognize c...
Status: RESOLVED DUPLICATE of bug 238949
Product: web
Classification: Unclassified
Component: AngularJS
8.0.1
All All
: P3 with 1 vote (vote)
: TBD
Assigned To: Roman Svitanic
Vladimir Riha
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2014-11-27 17:34 UTC by elennaro
Modified: 2014-11-28 10:41 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments
Screenshot of behavior (57.35 KB, image/png)
2014-11-27 17:34 UTC, elennaro
Details

Note You need to log in before you can comment on or make changes to this bug.
Description elennaro 2014-11-27 17:34:32 UTC
Created attachment 150753 [details]
Screenshot of behavior

When I write code like:

<script id="templates/tabs.html" type="text/ng-template">
  <div>This is my cool cached template</div>
</script>

All the content inside script tag should be recognized by Netbeans as HTML: it should be validated autocomplete must work etc.

However it is not and it is just black text.
See screenshot attached.

It wold be great if Netbeans could support text/ng-template type for scripts.
Or at least could recognize HTML inside such type of scripts.

Please see Angular Documentation on it:
https://docs.angularjs.org/api/ng/directive/script
https://docs.angularjs.org/api/ng/service/$templateCache

I thing it is more Bug then Enhancement, and I'd like to give this bug priority P2, if you don't mind, because it's too annoying to have dummy dead text instead of HTML in such kind of blocks.
Comment 1 Vladimir Riha 2014-11-28 10:41:27 UTC
Yes, right now only text/html is recognized as html in <script> but that won't work with Angular...

*** This bug has been marked as a duplicate of bug 238949 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo