Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 24893 - [TTV] Allow sorting by ANY column, not just visible
[TTV] Allow sorting by ANY column, not just visible
Status: RESOLVED FIXED
Product: platform
Classification: Unclassified
Component: Outline&TreeTable
3.x
All All
: P3 (vote)
: 4.x
Assigned To: Stanislav Aubrecht
issues@platform
:
: 35532 (view as bug list)
Depends on:
Blocks: 33281
  Show dependency treegraph
 
Reported: 2002-06-17 20:30 UTC by Torbjorn Norbye
Modified: 2008-12-22 20:16 UTC (History)
1 user (show)

See Also:
Issue Type: ENHANCEMENT
:


Attachments
Bugifx (11.41 KB, patch)
2004-11-09 14:06 UTC, Stanislav Aubrecht
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Torbjorn Norbye 2002-06-17 20:30:37 UTC
Currently, the List Options -> Sort menu allows me
to sort
by any of the visible columns. 

But I believe this menu should show ALL registered
columns,
not just those visible.

This is a lot like Mozilla's mail tool. It's
currently showing
the "Subject", "Sender" and "Date" fields, but if
I go to
the "View" menu, the "Sort By" submenu lists ALL
posssible
columns, and I can sort by for example "Size".
Comment 1 Jiri Rechtacek 2002-06-18 09:40:42 UTC
reassigning to Ales responsible for TreeTableView
Comment 2 Marek Grummich 2002-07-22 11:18:17 UTC
Set target milestone to TBD
Comment 3 Marek Grummich 2002-07-22 11:21:10 UTC
Set target milestone to TBD
Comment 4 Jiri Rechtacek 2003-09-15 14:10:57 UTC
*** Issue 35532 has been marked as a duplicate of this issue. ***
Comment 5 Stanislav Aubrecht 2004-11-09 14:06:01 UTC
Created attachment 18797 [details]
Bugifx
Comment 6 Stanislav Aubrecht 2004-11-09 14:08:13 UTC
all sortable invisible columns are now appended to the end of the
visible column list in the sort popup menu.

dafe, pls review
Comment 7 David Simonek 2004-12-07 15:06:36 UTC
Reviewed, OK. Sorry for big delay.
Comment 8 Stanislav Aubrecht 2004-12-07 16:05:50 UTC
fixed

Checking in src/org/openide/explorer/view/NodeTableModel.java;
/cvs/openide/src/org/openide/explorer/view/NodeTableModel.java,v  <--
 NodeTableModel.java
new revision: 1.21; previous revision: 1.20
done
Checking in src/org/openide/explorer/view/TreeTableView.java;
/cvs/openide/src/org/openide/explorer/view/TreeTableView.java,v  <-- 
TreeTableView.java
new revision: 1.68; previous revision: 1.67


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo