Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 24853 - [2004-05-06] IDE should be branded distribution of openide/core
[2004-05-06] IDE should be branded distribution of openide/core
Status: VERIFIED FIXED
Product: platform
Classification: Unclassified
Component: -- Other --
3.x
PC Linux
: P3 (vote)
: 4.x
Assigned To: Jaroslav Tulach
issues@platform
core-promod
:
Depends on: 31286
Blocks: 17815
  Show dependency treegraph
 
Reported: 2002-06-17 08:53 UTC by Jaroslav Tulach
Modified: 2008-12-22 19:45 UTC (History)
2 users (show)

See Also:
Issue Type: TASK
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jaroslav Tulach 2002-06-17 08:53:48 UTC
As discussed on nbdev@:

Should the NetBeans IDE be also a branded
application over the
platfrom? I mean that we shall change the text in
bundles of core and
autoupdate and openide to be IDE neutral and
create
Bundle_ide.properties files that would modify the
IDE sensitive strings
to contain the text more related to the IDE?
Comment 1 Marek Grummich 2002-07-22 08:33:46 UTC
Target milestone was changed from '3.4' to TBD.
Comment 2 Marek Grummich 2002-07-22 08:46:05 UTC
Target milestone was changed from '3.4' to TBD.
Comment 3 Jesse Glick 2004-03-30 13:35:08 UTC
You're working on this stuff.
Comment 4 Jaroslav Tulach 2004-03-30 17:30:14 UTC
Not exactly, I do not plan to provide real branding. Just separate
some modules into nb4.0 cluster. That is good start, but not real
branding. So it is probably ok to leave the target mileston as future.
Comment 5 _ ttran 2004-04-01 21:23:54 UTC
I'll attempt to do something about this issue because I already touch
the launcher scripts.

What I am going to do is

- at platform level put all branding related stuff in productinfo.jar
(product name, version, splash)
- then the NB IDE will brand that jar, say productinfo_nb.jar
- the netbeans launcher will run nbexec --branding nb (just hard code
it, no need for lib/branding file)

For starters I won't try to do anything too creative w/
productinfo.jar, just refactor stuff from core/openide there.  later
on we need a closer look at the content of this jar.  It's API

Sounds okay?

Jesse: what is the impact on performance of --branding nb?

Comment 6 Jesse Glick 2004-04-02 04:10:55 UTC
Setting a non-null branding will probably make startup time slightly
longer due to an increased number of resource lookups. I am not sure
how much.
Comment 7 _ ttran 2004-04-19 12:18:22 UTC
we'll attempt to do this in promo-d
Comment 8 Jaroslav Tulach 2004-05-02 19:15:54 UTC
promo-D is a nice milestone, but what exactly we wish to do? PS: I am
the original submitor of the request, but this seems more work and
mostly thinking than what I am ready to invest in next two weeks.
Changing to future, if there is a strict plan I am ready to evaluate
it for promo-D, however...
Comment 9 _ ttran 2004-05-04 22:59:27 UTC
Yarda, I don't want anything fancy here.  Take a look at {ffjcvs}/core
and {ffjcvs}/openide.  We only need to

- create ide/branding/core and ide/branding/openide
- put the branded stuff there, just a few Bundle.properties and one splash
- build core/core_nb.jar and core/openide_nb.jar
- replace the splash in core with the platfrom splash which I'll
attach shortly
- modify the netbeans launcher to always use "--branding nb" (check
startup time before commit please)

The goal is by the time we'll branch we'll only touch ide/branding and
ide/launcher, nothing else

Still too much work? :-)

Please pick your date and prefix the summary field with it, before
2004-05-15 if possible
Comment 10 Jesse Glick 2004-05-05 00:25:48 UTC
Careful with this - if you brand openide & core it means you have to
track the branded JARs in their own NBMs (otherwise you cannot
possibly use AU to ever update them). Supposedly there is some kind of
support for branding & localization in AU, but I do not know if it
actually works - very likely there is no test which covers it,
possibly it has not even been tried in a long time.
Comment 11 Jaroslav Tulach 2004-05-06 13:12:19 UTC
I've put the stuff in. Jesse is right, the branding is not perfect and
I will work on it as part of issue 36784. 

"#24853: NetBeans IDE is now branded version of NetBeans platform.
NetBeans IDE launchers start the system with --branding nb and this
changes the title to NetBeans IDE and has its own splash screen.
Future changes are of course posible"
Checking in
core/windows/src/org/netbeans/core/windows/view/ui/Bundle.properties;
/cvs/core/windows/src/org/netbeans/core/windows/view/ui/Bundle.properties,v
 <--  Bundle.properties
new revision: 1.8; previous revision: 1.7
done
Processing log script arguments...
More commits to come...
RCS file: /cvs/ide/branding/core/build.xml,v
done
Checking in ide/branding/core/build.xml;
/cvs/ide/branding/core/build.xml,v  <--  build.xml
initial revision: 1.1
done
Processing log script arguments...
More commits to come...
RCS file:
/cvs/ide/branding/core/src/org/netbeans/core/resources/splash_nb.gif,v
done
Checking in
ide/branding/core/src/org/netbeans/core/resources/splash_nb.gif;
/cvs/ide/branding/core/src/org/netbeans/core/resources/splash_nb.gif,v
 <--  splash_nb.gif
initial revision: 1.1
done
Processing log script arguments...
More commits to come...
RCS file: /cvs/ide/branding/core/windows/build.xml,v
done
Checking in ide/branding/core/windows/build.xml;
/cvs/ide/branding/core/windows/build.xml,v  <--  build.xml
initial revision: 1.1
done
Processing log script arguments...
More commits to come...
RCS file:
/cvs/ide/branding/core/windows/src/org/netbeans/core/windows/view/ui/Bundle_nb.properties,v
done
Checking in
ide/branding/core/windows/src/org/netbeans/core/windows/view/ui/Bundle_nb.properties;
/cvs/ide/branding/core/windows/src/org/netbeans/core/windows/view/ui/Bundle_nb.properties,v
 <--  Bundle_nb.properties
initial revision: 1.1
done
Processing log script arguments...
More commits to come...
Checking in ide/launcher/unix/netbeans;
/cvs/ide/launcher/unix/netbeans,v  <--  netbeans
new revision: 1.2; previous revision: 1.1
done
Processing log script arguments...
More commits to come...
Checking in ide/launcher/windows/netbeans.cpp;
/cvs/ide/launcher/windows/netbeans.cpp,v  <--  netbeans.cpp
new revision: 1.2; previous revision: 1.1
done
Processing log script arguments...
More commits to come...
Checking in nbbuild/build.properties;
/cvs/nbbuild/build.properties,v  <--  build.properties
new revision: 1.171; previous revision: 1.170
done
Checking in nbbuild/build.xml;
/cvs/nbbuild/build.xml,v  <--  build.xml
new revision: 1.468; previous revision: 1.467
done
Checking in nbbuild/cluster.properties;
/cvs/nbbuild/cluster.properties,v  <--  cluster.properties
new revision: 1.27; previous revision: 1.26
done
Comment 12 _ ttran 2004-05-06 17:18:42 UTC
netbeans.exe and nb.exe recompiled and checked in CVS
Comment 13 Marian Mirilovic 2005-12-20 15:47:36 UTC
This issue was solved long time ago. Because nobody has reopened it neither
added comments, we are verifying/closing it now. 
If you are still able to reproduce the problem, please reopen. Thanks in advance.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo