Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 248424 - IllegalStateException: Module org.openide.execution is already enabled
IllegalStateException: Module org.openide.execution is already enabled
Status: RESOLVED DUPLICATE of bug 247884
Product: platform
Classification: Unclassified
Component: Module System
8.1
All All
: P2 (vote)
: TBD
Assigned To: Svata Dedic
issues@platform
EXCEPTIONS_REPORT
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2014-11-05 14:18 UTC by palman
Modified: 2014-11-13 12:00 UTC (History)
3 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
stacktrace (6.76 KB, text/plain)
2014-11-05 14:18 UTC, palman
Details

Note You need to log in before you can comment on or make changes to this bug.
Description palman 2014-11-05 14:18:54 UTC
Build: NetBeans IDE Dev (Build 201411050002)
VM: Java HotSpot(TM) 64-Bit Server VM, 25.40-b16, Java(TM) SE Runtime Environment, 1.8.0_40-ea-b12
OS: Mac OS X

User Comments:
palman: fresh install netbeans dev, try to open java ee project

helderneres: Enabling modules...




Stacktrace: 
java.lang.IllegalStateException: Module org.openide.execution is already enabled
   at org.netbeans.ModuleManager.attachModuleFragment(ModuleManager.java:1019)
   at org.netbeans.ModuleManager.maybeAddToEnableList(ModuleManager.java:1585)
   at org.netbeans.ModuleManager.maybeAddToEnableList(ModuleManager.java:1595)
   at org.netbeans.ModuleManager.maybeAddToEnableList(ModuleManager.java:1623)
   at org.netbeans.ModuleManager.maybeAddToEnableList(ModuleManager.java:1595)
   at org.netbeans.ModuleManager.maybeAddToEnableList(ModuleManager.java:1595)
Comment 1 palman 2014-11-05 14:18:55 UTC
Created attachment 150295 [details]
stacktrace
Comment 2 Jaroslav Tulach 2014-11-12 16:05:30 UTC
Another one for Sváťa and his fragments.
Comment 3 Svata Dedic 2014-11-13 12:00:03 UTC
Autoupdate Wizard is in control; it should check prior to enabling modules that none of the added modules is a fragment of an already enabled module. Or handle the error by suggesting IDE restart - see defect #247884

*** This bug has been marked as a duplicate of bug 247884 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo