Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 248010 - Subword completion does not propose most correct match
Subword completion does not propose most correct match
Status: VERIFIED FIXED
Product: java
Classification: Unclassified
Component: Editor
8.0.1
PC Windows 7
: P3 (vote)
: 8.1
Assigned To: Dusan Balek
issues@java
:
: 241749 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2014-10-18 06:32 UTC by markiewb
Modified: 2015-08-03 19:15 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments
Example (50.90 KB, image/png)
2014-10-18 06:32 UTC, markiewb
Details

Note You need to log in before you can comment on or make changes to this bug.
Description markiewb 2014-10-18 06:32:38 UTC
Created attachment 149970 [details]
Example

Example:

* Multiple variables "values", "valueToSet" are defined in code
* complete "valus|" (| defines the caret)

ACTUAL:
"valueToSet" is proposed and selected (higher prio than "values")

EXPECTED:
"values" is proposed and selected (higher prio than "valueToSet")
Comment 1 markiewb 2014-10-18 06:33:44 UTC
Perhaps my issue is a dup of https://netbeans.org/bugzilla/show_bug.cgi?id=241749 ?
Comment 2 Dusan Balek 2014-10-20 08:48:08 UTC
Fixed in jet-main.

http://hg.netbeans.org/jet-main/rev/29ffe65d3a51
Comment 3 Quality Engineering 2014-10-29 11:41:37 UTC
Integrated into 'main-silver', will be available in build *201410290913* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)

Changeset: http://hg.netbeans.org/main-silver/rev/29ffe65d3a51
User: Dusan Balek <dbalek@netbeans.org>
Log: Issue #248010: Subword completion does not propose most correct match - fixed.
Comment 4 markiewb 2015-03-26 22:50:53 UTC
*** Bug 241749 has been marked as a duplicate of this bug. ***
Comment 5 markiewb 2015-04-03 07:55:12 UTC
Verified. Works fine. Thank you!

Product Version: NetBeans IDE Dev (Build 201504030001)
Java: 1.8.0_40; Java HotSpot(TM) 64-Bit Server VM 25.40-b25
Runtime: Java(TM) SE Runtime Environment 1.8.0_40-b25


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo