Bug 247673 - "New Project" wizard works too slowly in FullRemote case
"New Project" wizard works too slowly in FullRemote case
Status: VERIFIED FIXED
Product: cnd
Classification: Unclassified
Component: Remote
8.0.1
PC Solaris
: P3 (vote)
: 8.2
Assigned To: Vladimir Kvashin
issues@cnd
82patch1-verified
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2014-10-03 14:07 UTC by soldatov
Modified: 2016-12-10 02:59 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments
A prototype for patch (18.60 KB, patch)
2016-11-22 13:13 UTC, Vladimir Kvashin
Details | Diff
Step 2 - remote FS suspend/resume. Not tested enough so far... (19.91 KB, patch)
2016-12-06 08:46 UTC, Vladimir Kvashin
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description soldatov 2014-10-03 14:07:41 UTC
Theoretically FullRemote is a nice feature in order to demonstrate remote C/C++ development. But  missed ~35 seconds in order to create simplest project with 1 source file ("Arguments" sample) kills any wow effect.

=========================================================================
| action                              |   response time      | terminal |
|                                     |======================|          |
|                                     | 1ms  | 250ms | 750ms |          |
=========================================================================
| add new host                        | 23s  | 36s   | 66s   |  -       |
| create new project (OSS, Welcome)   | 5s   | 37s   | 102s  |  -       |
| build project (OSS, Quote)          | 21s  | 87s   | 231s  |  6s      |
=========================================================================
Comment 1 Vladimir Kvashin 2016-11-22 13:13:19 UTC
Created attachment 162980 [details]
A prototype for patch
Comment 2 Vladimir Kvashin 2016-11-22 13:24:11 UTC
Confirmed. 

I tried to create a Quote on a host with ~220. I measured as follows: I connected to host, started project creation, waited until "finish" button is available, waited until all remote related activity finishes (I see this in log since I launch IDE with -J-Dnativeexecution.support.logger.level=0 -J-Dremote.support.logger.level=0). Then I measured time from the moment when "finish" was pressed till the wizard disappears and the project in project pane appears.

This took about 80 seconds.

If we switch off remote VCS via -J-Dremote.vcs.suport=false
then it takes about 50 seconds.

With attached fix prototype and with remote VCS switched OFF, it takes 12 seconds. I'll work on the complete production level fix shortly.
Comment 3 Vladimir Kvashin 2016-11-22 13:47:51 UTC
The above concerns creating sample projects only.

As to projects from existing code, if Studio is available on remote host then this should be done via project_creator. If it is slow either I propose to file this as a separate bug.

Managed projects are not affected by this fix either.
Comment 4 Alexander Simon 2016-11-22 14:02:50 UTC
(In reply to Vladimir Kvashin from comment #3)
> The above concerns creating sample projects only.
> 
> As to projects from existing code, if Studio is available on remote host
> then this should be done via project_creator.

It is not proved assertion.
Please provide more evidence.

Thanks,
Alexander
Comment 5 Vladimir Kvashin 2016-12-06 08:46:30 UTC
Created attachment 163162 [details]
Step 2 - remote FS suspend/resume. Not tested enough so far...
Comment 6 Vladimir Kvashin 2016-12-07 10:55:45 UTC
fixed on enum/release82
069af9973547
2b4e36d7aeb6
103e4ca88674
caea5a36ecc7
2cc282580e3c
2a4669ea2a6e
46d7442f1121
244b2a1842ac
Comment 7 Vladimir Kvashin 2016-12-07 11:14:09 UTC
Quote is now created within 7 seconds on a host in SCA
Comment 8 soldatov 2016-12-07 12:59:56 UTC
Verified in internal NetBeans 8,2 patch 1 build.
Comment 9 Quality Engineering 2016-12-08 02:37:08 UTC
Integrated into 'main-silver', will be available in build *201612080001* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)

Changeset: http://hg.netbeans.org/main-silver/rev/6ae8fd81dfe5
User: Vladimir Kvashin <vkvashin@netbeans.org>
Log: refactoring before fixing #247673 - "New Project" wizard works too slowly in FullRemote case
(transplanted from 244b2a1842ac32c033a0e2f8c56b6702651b0eb5)
Comment 10 Quality Engineering 2016-12-09 02:40:45 UTC
Integrated into 'main-silver', will be available in build *201612090001* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)

Changeset: http://hg.netbeans.org/main-silver/rev/688a463f2a43
User: Vladimir Kvashin <vkvashin@netbeans.org>
Log: Remote FS suspend/resume - fixing #247673 - "New Project" wizard works too slowly in FullRemote case
(transplanted from 069af99735474405cb57a149c5a2b16819d7478b)
Comment 11 Quality Engineering 2016-12-10 02:59:19 UTC
Integrated into 'main-silver', will be available in build *201612100001* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)

Changeset: http://hg.netbeans.org/main-silver/rev/e650c721f111
User: Vladimir Kvashin <vkvashin@netbeans.org>
Log: i18n after fixing #247673 New Project wizard works too slowly in FullRemote
(transplanted from 4df8ff9ce9db5f03c7fdc75034cf292d328f9f3e)


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo