Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 247615 - Allow opening any git repo to Git Repository Browser
Allow opening any git repo to Git Repository Browser
Status: RESOLVED FIXED
Product: versioncontrol
Classification: Unclassified
Component: Git
8.0.1
All All
: P3 (vote)
: 8.1
Assigned To: Ondrej Vrabec
issues@versioncontrol
:
: 248392 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2014-10-01 07:23 UTC by hifi
Modified: 2014-11-04 12:58 UTC (History)
2 users (show)

See Also:
Issue Type: ENHANCEMENT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description hifi 2014-10-01 07:23:35 UTC
NetBeans' git integration is fairly complete and can be very useful to manage external projects outside NetBeans in some situations where you don't have a "NetBeans Project" or native git installed.

Suggested feature would be to have "Team -> Git -> Open..." (and "Team -> Remote -> Open..." when in git context) to open any git repository to Git Repository Browser.

This would also require the right click context menu on the repository itself in the browser to have "Repository -> Close" function to close any open repository. Bug 247614 could also be resolved using this.
Comment 1 Ondrej Vrabec 2014-10-01 07:29:00 UTC
Bug 247614 is WONTFIX, i agree there could be "Close" in the browser to get rid of the repo off the view.
And something like open repo makes sense too.
Comment 2 Ondrej Vrabec 2014-10-01 07:31:57 UTC
BTW, as i noted in bug 247614, there is the Favorites view which is pretty much the view for browsing files that are not part of any NetBeans project. Once you browse the view and navigate to the git repository there, it will be auto added to the repository browser view.
Comment 3 hifi 2014-10-01 07:39:56 UTC
(In reply to Ondrej Vrabec from comment #2)
> BTW, as i noted in bug 247614, there is the Favorites view which is pretty
> much the view for browsing files that are not part of any NetBeans project.
> Once you browse the view and navigate to the git repository there, it will
> be auto added to the repository browser view.

It's not that easy to discover as I don't for example ever use that view in my day to day work where all open files belong to a NetBeans project. However, that is also convenient to exist.

That with the ability to manually open and close a git repository using the menus will make it more discoverable for many I would think and fixes "sticky" repositories which is an actual issue.
Comment 4 Ondrej Vrabec 2014-10-03 09:54:28 UTC
fixed: core-main #2cac4f5d6071
Comment 5 Quality Engineering 2014-10-05 02:04:53 UTC
Integrated into 'main-silver', will be available in build *201410050001* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)

Changeset: http://hg.netbeans.org/main-silver/rev/2cac4f5d6071
User: Ondrej Vrabec <ovrabec@netbeans.org>
Log: Issue #247615 - Allow opening any git repo to Git Repository Browser
Comment 6 hifi 2014-10-05 07:08:12 UTC
I've downloaded the latest nightly and tested the functionality to work as expected as well as closing any open repository.

Thank you.
Comment 7 Ondrej Vrabec 2014-11-04 12:58:49 UTC
*** Bug 248392 has been marked as a duplicate of this bug. ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo