Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 247045 - Static imports hint should ignore patterns like String.class
Static imports hint should ignore patterns like String.class
Status: RESOLVED DUPLICATE of bug 250756
Product: java
Classification: Unclassified
Component: Hints
8.0.1
PC Windows 7
: P3 with 1 vote (vote)
: 8.1
Assigned To: Svata Dedic
issues@java
:
Depends on: 89258
Blocks:
  Show dependency treegraph
 
Reported: 2014-09-11 18:59 UTC by markiewb
Modified: 2015-04-15 13:38 UTC (History)
1 user (show)

See Also:
Issue Type: ENHANCEMENT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description markiewb 2014-09-11 18:59:22 UTC
Follow up to https://netbeans.org/bugzilla/show_bug.cgi?id=89258#c59

```
Can this be modified to exclude references to the static "class" variable?  I just tried to run this, and i'm using the class objects fairly throughly, and this check suggested import static java.lang.String.class AND import static java.lang.Double.class.
```

EXPECTED: Static imports hint should ignore patterns like String.class
Comment 1 Svata Dedic 2015-04-15 13:38:37 UTC

*** This bug has been marked as a duplicate of bug 250756 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo