Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 246941 - In Mac OSX, unable to double click to open a generic text file for editing
In Mac OSX, unable to double click to open a generic text file for editing
Status: RESOLVED DUPLICATE of bug 138943
Product: utilities
Classification: Unclassified
Component: Open File
8.0
Macintosh Mac OS X
: P3 (vote)
: TBD
Assigned To: Jaroslav Havlin
issues@utilities
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2014-09-09 10:33 UTC by johnny_beans
Modified: 2014-09-12 13:07 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description johnny_beans 2014-09-09 10:33:15 UTC
In Mac OSX, unable to open a generic text file for editing with the following actions:
 1. Double clicking on the file (having set Netbeans as the default program)
 2. Dragging the file onto the icon

The only way that is not a pain to open is by dragging the file into an empty editor position. As there is only an empty editor when there are no files, this is not always useful.

I am able to open through the File menu, or through Favorites, but it is not very nice.

Thanks

Product Version = NetBeans IDE 8.0 (Build 201403101706)
Operating System = Mac OS X version 10.9.4 running on x86_64
Java; VM; Vendor = 1.8.0_11
Runtime = Java HotSpot(TM) 64-Bit Server VM 25.11-b03
Comment 1 Jaroslav Havlin 2014-09-12 13:07:06 UTC
> The only way that is not a pain to open is by dragging the file into an empty
> editor position. As there is only an empty editor when there are no files,
> this is not always useful.
You can drag the file into editor area even if some files are already opened. At least it worked for me with Mac OS X 10.9.4 and NetBeans 8.0 (drop the dragged file on already opened document's editor pane).

*** This bug has been marked as a duplicate of bug 138943 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo