Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 245732 - NB8 ActiveQueue doesn't work properly with JDK9
NB8 ActiveQueue doesn't work properly with JDK9
Status: RESOLVED FIXED
Product: platform
Classification: Unclassified
Component: -- Other --
8.1
PC All
: P2 (vote)
: 8.0.2
Assigned To: Jaroslav Tulach
issues@platform
:
: 251701 251851 252246 252458 252806 252938 253536 (view as bug list)
Depends on: 206621
Blocks: 184192
  Show dependency treegraph
 
Reported: 2014-07-16 13:57 UTC by lothe
Modified: 2015-08-21 05:51 UTC (History)
7 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
More reflection to make the code work on JDK9 (2.05 KB, patch)
2014-07-18 11:40 UTC, Jaroslav Tulach
Details | Diff
Code can be greatly simplified once the removeWhileExists is available (3.12 KB, patch)
2014-07-24 11:22 UTC, Jaroslav Tulach
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description lothe 2014-07-16 13:57:39 UTC
NB8 ActiveQueue doesn't work properly with JDK9, making many tests it is involved in fail by timeout.
Comment 1 Jaroslav Tulach 2014-07-17 07:47:01 UTC
Regression introduced by 

> changeset: 0731952efb10
> user: igerasim
> date: Thu Feb 27 02:44:04 2014 +0400
> summary: 6853696: (ref) ReferenceQueue.remove(timeout) may return null 
> even if timeout has not expired

but something that should be addressed on the NetBeans side (as there are nasty tricks with reflection in ActiveQueue which just got broken by the 0731952efb10 change).
Comment 2 Jaroslav Tulach 2014-07-18 11:40:07 UTC
Created attachment 148132 [details]
More reflection to make the code work on JDK9
Comment 3 Jaroslav Tulach 2014-07-18 11:48:47 UTC
With the previous patch all openide.util.lookup as well as openide.util tests pass on JDK9b04. However I don't like the solution much (even more reflection than before) and will try to come up with proper fix on the JDK side.
Comment 4 Jaroslav Tulach 2014-07-24 09:54:10 UTC
Rather than hacking on NetBeans side, I decided to share the love and improve JDK: https://bugs.openjdk.java.net/browse/JDK-8051843
Comment 5 Jaroslav Tulach 2014-07-24 11:22:12 UTC
Created attachment 148275 [details]
Code can be greatly simplified once the removeWhileExists is available
Comment 6 Jaroslav Tulach 2014-07-28 09:37:34 UTC
I won't fix this problem for 8.0.1.
Comment 7 Jaroslav Tulach 2014-11-14 13:26:19 UTC
https://hg.netbeans.org/ergonomics/rev/0dc25ad5ba37
Comment 8 Quality Engineering 2014-11-21 03:50:43 UTC
Integrated into 'main-silver', will be available in build *201411210001* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)

Changeset: http://hg.netbeans.org/main-silver/rev/0dc25ad5ba37
User: Jaroslav Tulach <jtulach@netbeans.org>
Log: #245732: Discussions on JDK's core-libs mailing list revealed that the changes that the API of JDK is enhanced to allow clean fix of the problem is extremlly low, so adding more reflection to make the test work on JDK9
Comment 9 Tomas Stupka 2015-05-18 11:42:29 UTC
> Regression introduced by 
> > changeset: 0731952efb10
> > user: igerasim
> > date: Thu Feb 27 02:44:04 2014 +0400
> > summary: 6853696: (ref) ReferenceQueue.remove(timeout) may return null 
> > even if timeout has not expired
> but something that should be addressed on the NetBeans side (as there are nasty tricks with reflection in ActiveQueue which just got broken by the 0731952efb10 change).
was backported to jdk 1.8.0_40 
so we should also backport jardas patch to nb 8.0.2
Comment 10 Tomas Stupka 2015-05-18 11:43:10 UTC
*** Bug 251851 has been marked as a duplicate of this bug. ***
Comment 11 Tomas Stupka 2015-05-18 12:09:44 UTC
backported to releases #f7c199a16490 branch release801
Comment 12 Tomas Stupka 2015-05-18 12:13:37 UTC
*** Bug 251701 has been marked as a duplicate of this bug. ***
Comment 13 Tomas Hurka 2015-05-18 12:15:24 UTC
*** Bug 252458 has been marked as a duplicate of this bug. ***
Comment 14 Petr Pisl 2015-05-25 09:24:31 UTC
*** Bug 252246 has been marked as a duplicate of this bug. ***
Comment 15 Quality Engineering 2015-05-27 13:18:24 UTC
Integrated into 'releases/release801', will be available in build *201505271203* or newer. Wait for official and publicly available build.

Changeset: http://hg.netbeans.org/releases/rev/f7c199a16490
User: Jaroslav Tulach <jtulach@netbeans.org>
Log: #245732: Discussions on JDK's core-libs mailing list revealed that the changes that the API of JDK is enhanced to allow clean fix of the problem is extremlly low, so adding more reflection to make the test work on JDK9
Comment 16 Tomas Hurka 2015-06-05 11:48:50 UTC
*** Bug 252806 has been marked as a duplicate of this bug. ***
Comment 17 Tomas Hurka 2015-06-12 07:58:02 UTC
*** Bug 252938 has been marked as a duplicate of this bug. ***
Comment 18 Tomas Stupka 2015-06-12 08:42:31 UTC
available on 8.0.2 Update Center via the following module 
org.openide.util.lookup [8.25.2 201505281753]
Comment 19 Jaroslav Havlin 2015-08-07 14:37:24 UTC
*** Bug 253536 has been marked as a duplicate of this bug. ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo