Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 245637 - Cannot download JUnit JAR
Cannot download JUnit JAR
Status: RESOLVED FIXED
Product: java
Classification: Unclassified
Component: JUnit
8.0.1
PC Linux
: P2 with 1 vote (vote)
: 8.1
Assigned To: Theofanis Oikonomou
junit-issues@java
:
: 247568 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2014-07-14 10:10 UTC by Jaroslav Tulach
Modified: 2015-05-29 04:18 UTC (History)
5 users (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jaroslav Tulach 2014-07-14 10:10:47 UTC
JUnit library has been re-licensed under acceptable Eclipse Public License. There is no reason to mess with downloading it separately.

Special treatment of JUnit complicates the build process as well as installer. Remove it and treat JUnit as any other 3rd party library.
Comment 1 Theofanis Oikonomou 2014-07-16 15:49:58 UTC
(In reply to Jaroslav Tulach from comment #0)
> JUnit library has been re-licensed under acceptable Eclipse Public License.

~a year ago

> There is no reason to mess with downloading it separately.

agree

> 
> Special treatment of JUnit complicates the build process as well as
> installer. Remove it and treat JUnit as any other 3rd party library.

AFAIK until there is an official release with the new license we cannot proceed with removing the "special treatment".
Comment 2 Theofanis Oikonomou 2014-09-30 10:20:32 UTC
*** Bug 247568 has been marked as a duplicate of this bug. ***
Comment 3 Jaroslav Tulach 2014-10-01 01:14:43 UTC
Duplicate issue was P2
Comment 4 Theofanis Oikonomou 2014-11-27 11:38:49 UTC
4.12-beta-3 was recently out so it looks this can be scheduled for next release
Comment 5 Jaroslav Tulach 2014-11-28 04:46:29 UTC
What do you mean by next release? 8.1? Isn't the right target "Dev" then?

Why do you care about JUnit 4.12-beta? The relicensing happened one and half year ago https://github.com/junit-team/junit/blob/master/epl-v10.html
and at least 4.11 has been stable release released since then?
Comment 6 Theofanis Oikonomou 2014-11-28 10:24:04 UTC
(In reply to Jaroslav Tulach from comment #5)
> What do you mean by next release? 8.1? Isn't the right target "Dev" then?

correct, my mistake.

> 
> Why do you care about JUnit 4.12-beta? The relicensing happened one and half
> year ago https://github.com/junit-team/junit/blob/master/epl-v10.html
> and at least 4.11 has been stable release released since then?

the library was relicensed 1.5 years ago but 4.11 was already released for half a year already. AFAIK there must be a final release (meaning 4.12) that contains the new license so that the legal process for approval can start. When this happens I will remove the extra steps needed for configuring junit support in netbeans.
Comment 7 _ tboudreau 2015-03-12 01:24:23 UTC
One thing that would work on a lot of developer machines:

See if ~/.m2/junit/junit/4.11/junit-4.11.jar exists and if yes, use that.  I find it particularly silly that it tries to download it when another part of the IDE knows that it exists on disk.
Comment 8 Theofanis Oikonomou 2015-04-21 12:19:59 UTC
Should be fixed: http://hg.netbeans.org/web-main/rev/459035808e45
Comment 9 Theofanis Oikonomou 2015-05-28 11:00:53 UTC
Extra fix related to removing junit-3.x binaries and library definition : http://hg.netbeans.org/core-main/rev/b8ed12ff61bf
Comment 10 Jaroslav Tulach 2015-05-29 04:18:44 UTC
Congrats on finally solving this long standing issue!


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo