Bug 245527 - Update signatures with ES6
Update signatures with ES6
Status: RESOLVED FIXED
Product: javascript
Classification: Unclassified
Component: Documentation
8.0.1
PC Linux
: P3 with 2 votes (vote)
: 8.2
Assigned To: Petr Pisl
issues@javascript
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2014-07-09 14:36 UTC by Vladimir Riha
Modified: 2016-08-16 14:10 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Vladimir Riha 2014-07-09 14:36:00 UTC
Would it be possible to update signatures to contain new methods (functions, objects, ...) from EcmaScript 6 (Promise, Set, setPrototypeOf(), observe() etc.)? Something is already supported in latest browsers.
Comment 1 denis.peplin 2014-09-24 06:51:31 UTC

*** This bug has been marked as a duplicate of bug 242387 ***
Comment 2 Vladimir Riha 2014-09-24 07:17:51 UTC
IMHO not a duplicate, this is about getting new methods/functions for core objects like Promise, Array, Object etc., not about new syntax features.
Comment 3 Petr Pisl 2016-08-16 14:10:36 UTC
Done in dev builds of NB 8.2


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo