Bug 24533 - db connections (and own driver) are gone on restart
db connections (and own driver) are gone on restart
Status: CLOSED WORKSFORME
Product: db
Classification: Unclassified
Component: Code
3.x
PC Windows ME/2000
: P4 (vote)
: 3.x
Assigned To: issues@db
issues@db
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2002-06-07 13:36 UTC by swb
Modified: 2003-06-30 17:17 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description swb 2002-06-07 13:36:29 UTC
when I use the DB explorer to add a new connection
(DB2 net), all works fine. The next time I restart
NB, the connection is gone and I have to recreate
it. The same with DB drivers not in list. When I
add a new driver, the next time I restart NB, its
entry is gone. I first encountered the problem
with NB 3.4 MS4. I updated to Q-build
200205282200, but the bug was still there. Before
I used NB 3.3.1 and all worked as expected. I
converted my 3.3.1 user dir into 3.4dev
Comment 1 swb 2002-06-24 15:11:40 UTC
after resolving some file system issues (NB didn't have full access to
its user directory), all works again as I expect it. I think Windows
2000 confused something on copying the user directories from older
version and between different profiles.
Comment 2 Radko Najman 2002-07-03 15:44:34 UTC
Update from NetBeans 3.4 beta 1 to Netbeans 3.4 beta 2. It seems that
the update solves this issue.
Comment 3 swb 2002-07-08 08:00:10 UTC
The issue is also there with NB 3.4beta2, and the changing of access
rights doesn't seem to solve it really.
I found another way to solve it, which was verified by at least one
other person.
Under "Tools -> Options" scroll down to the bottom where you can find
"Database Explorer", now show the levels (press "+" or the "<<" button
on the top of the window). If only the level "Project" is set, it
doesn't seem to work. Now click into the "User" column and choose
"define here" and accept the change. Close the option window, create a
new connection (or add the new driver...) and restart. It should work now.
Comment 4 Martin Schovanek 2003-03-12 18:29:53 UTC
VERIFIED
Comment 5 Martin Schovanek 2003-03-12 18:30:15 UTC
VERIFIED
Comment 6 Quality Engineering 2003-06-30 17:17:41 UTC
Resolved for 3.3.x or earlier, no new info since then -> closing.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo