Bug 24521 - I18N - Enhance API's (where necessary) to be able to pass mnemonic key separately from the text.
I18N - Enhance API's (where necessary) to be able to pass mnemonic key separa...
Status: RESOLVED DUPLICATE of bug 26678
Product: platform
Classification: Unclassified
Component: -- Other --
3.x
PC All
: P2 (vote)
: TBD
Assigned To: Jaroslav Tulach
issues@platform
: API, I18N
Depends on:
Blocks: 23879
  Show dependency treegraph
 
Reported: 2002-06-07 10:04 UTC by Peter Zavadsky
Modified: 2008-12-22 16:57 UTC (History)
2 users (show)

See Also:
Issue Type: TASK
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Peter Zavadsky 2002-06-07 10:04:37 UTC
The technique used in NB widelly usging '&' to
mark mnemonic key seems to be insufficient.

It doesn't work for languages like japanese, were
the mnemonic key isn't contained in the label string.

E.g. see the issue #23879, were this problem is
with NotifyDescriptor.InputLine. (Overriding the
createDesign method for this case seems to be too
costly and non-elegant).
I think there are many places in OpenAPI needed
this enhancement.

Separating the mnemonic key from the label text
would solve the issue and also I guess it would
conform more to the java style, were those values
are handled like two properties, which in fact
they are.
Comment 1 Ken Frank 2002-06-07 15:43:24 UTC
added I18N to synopsis and keyword as it helps us track i18n issues

ken.frank@sun.com
06/07/2002
Comment 2 Marek Grummich 2002-07-22 11:15:43 UTC
Set target milestone to TBD
Comment 3 Marek Grummich 2002-07-22 11:18:49 UTC
Set target milestone to TBD
Comment 4 _ mihmax 2002-08-21 22:38:03 UTC
2 Ken:
Why is it insufficient?
Maybe it's simply better to use 
"<SOME JAPANESE TEXT> (&F)", but make Netbeans action 
system be smarter and omit " (&F)" where no mnemonics can 
be used?

(or I misunderstand your problem?)

Tor Norbye suggested to extend Actions.java with the 
method to commonly handle Labels as currently are handled 
Buttons and Menu Items: see issue 26678
Comment 5 Jaroslav Tulach 2002-08-28 09:32:52 UTC
Maxim, I do not know why it is insuficient. I believe that we made a
huge step forward as part of issue 26678. Marking as duplicate of that
issue.


*** This issue has been marked as a duplicate of 26678 ***
Comment 6 _ mihmax 2002-08-28 09:40:55 UTC
Well, then, I suppose, all the bundles should be modified 
to use only "&Symbol" format rather then "Symbol" + 
_mnem="S"
Comment 7 Ken Frank 2002-08-28 16:51:37 UTC
I just wanted to be sure that this relates to 26678 since
that one appears to be requesting that non ascii characters
be allowed for mnemonic key, but this rfe was referring to
mechanism of the mnemonic approach itself (& method vs
the 2 keys per mnemonic approach)

And localization center for FFJ uses only ascii keys on
us keyboard as possible mnemobnics - the only short term
issue they had with & approach was that in all cases
the & should be put since without it, it defaults I think
to first letter of label, which in case of localized,
would not be correct letter.

ken.frank@sun.com
08/28/2002


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo