Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 244420 - OutOfMemoryError: GC overhead limit exceeded
OutOfMemoryError: GC overhead limit exceeded
Status: RESOLVED DUPLICATE of bug 249165
Product: web
Classification: Unclassified
Component: HTML Project
8.0
All All
: P3 (vote)
: 8.1
Assigned To: Tomas Mysik
issues@web
EXCEPTIONS_REPORT
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2014-05-10 21:13 UTC by henri127
Modified: 2015-07-28 13:35 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments
stacktrace (939 bytes, text/plain)
2014-05-10 21:13 UTC, henri127
Details

Note You need to log in before you can comment on or make changes to this bug.
Description henri127 2014-05-10 21:13:04 UTC
Build: NetBeans IDE 8.0 (Build 201403101706)
VM: Java HotSpot(TM) 64-Bit Server VM, 25.0-b70, Java(TM) SE Runtime Environment, 1.8.0-b132
OS: Windows 7

User Comments:
GUEST: I did a git stash on about 5 files ~ 200 lines were modified.  Switched branches, git stash applied.

henri127: after restart of pc from sleep mode and adjustements in code, netbeans became unresponsive




Stacktrace: 
java.lang.OutOfMemoryError: GC overhead limit exceeded
   at org.netbeans.lib.editor.util.PriorityListenerList.allocateTArray(PriorityListenerList.java:270)
   at org.netbeans.lib.editor.util.PriorityListenerList.add(PriorityListenerList.java:117)
   at org.netbeans.lib.editor.util.swing.DocumentUtilities.addPriorityDocumentListener(DocumentUtilities.java:136)
   at org.netbeans.editor.BaseDocument.addDocumentListener(BaseDocument.java:1869)
   at org.netbeans.spi.editor.highlighting.support.OffsetsBag.<init>(OffsetsBag.java:129)
   at org.netbeans.modules.editor.impl.highlighting.AnnotationsHighlighting$R.refreshAllLines(AnnotationsHighlighting.java:176)
Comment 1 henri127 2014-05-10 21:13:06 UTC
Created attachment 147215 [details]
stacktrace
Comment 2 Exceptions Reporter 2015-05-06 11:51:52 UTC
This bug already has 5 duplicates 
see http://statistics.netbeans.org/exceptions/detail.do?id=206529
Comment 3 Milutin Kristofic 2015-07-28 12:49:29 UTC
Many Strings, URLS from. See report 777394


org.netbeans.modules.web.clientproject.libraries.CDNJSLibrariesProvider.getFiles(CDNJSLibrariesProvider.java:378)
	at org.netbeans.modules.web.clientproject.libraries.CDNJSLibrariesProvider.createLibrary(CDNJSLibrariesProvider.java:366)
	at org.netbeans.modules.web.clientproject.libraries.CDNJSLibrariesProvider.readLibraries(CDNJSLibrariesProvider.java:220)
	at org.netbeans.modules.web.clientproject.libraries.CDNJSLibrariesProvider.getLibraries(CDNJSLibrariesProvider.java:118)
	at org.netbeans.modules.web.clientproject.api.WebClientLibraryManager.addLibraries(WebClientLibraryManager.java:311)
	at org.netbeans.modules.web.clientproject.api.WebClientLibraryManager.getLibraries(WebClientLibraryManager.java:219)
Comment 4 Tomas Mysik 2015-07-28 13:35:23 UTC

*** This bug has been marked as a duplicate of bug 249165 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo