Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 244287 - Feature Request: Timed Backup of Open Files
Feature Request: Timed Backup of Open Files
Status: RESOLVED WONTFIX
Product: editor
Classification: Unclassified
Component: Options
8.0
PC Windows 7
: P3 (vote)
: TBD
Assigned To: Milutin Kristofic
issues@editor
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2014-05-04 23:10 UTC by michaelmilette
Modified: 2016-07-07 07:27 UTC (History)
0 users

See Also:
Issue Type: ENHANCEMENT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description michaelmilette 2014-05-04 23:10:27 UTC
NEW FEATURE REQUEST

Please implement automatic timed backups of open files. This feature is similar to other products that already have it like Microsoft Word and Notepad++.

HOW IT WOULD WORK

Timed backup would save any changed unsaved work periodically until the file is saved. In the event that NetBeans crashes, upon restart, the unsaved files would be restored. The temporary backup, stored in a tmp folder, would be automatically deleted if the user closes the file.

The interval between saves would be an option in the NetBeans settings and could be disabled by specifying a 0 (zero) time interval.

WHAT IT IS NOT

This is not to be confused with file timed save which would saves your file periodically. I personally find this to be a pain as sometimes I work in files but don't want to save the changes.

WHY THIS IS IMPORTANT

As a result of the implementation of this new feature, gone would be the days when users potentially loose hours of work because they forgot to periodically save their work.
Comment 1 Martin Balin 2016-07-07 07:27:19 UTC
This old bug may not be relevant anymore. If you can still reproduce it in 8.2 development builds please reopen this issue.

Thanks for your cooperation,
NetBeans IDE 8.2 Release Boss


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo