Bug 244180 - Exception: resume without suspend 0
Exception: resume without suspend 0
Status: VERIFIED FIXED
Product: cnd
Classification: Unclassified
Component: Code Model
8.0
All All
: P2 (vote)
: 8.2
Assigned To: Vladimir Voskresensky
issues@cnd
EXCEPTIONS_REPORT, 82patch1-verified
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2014-04-29 17:27 UTC by tbrunhoff
Modified: 2016-12-12 09:02 UTC (History)
4 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
stacktrace (948 bytes, text/plain)
2014-04-29 17:27 UTC, tbrunhoff
Details
stacktrace (1.07 KB, text/plain)
2014-07-22 12:28 UTC, Alexander Simon
Details
stacktrace (1.07 KB, text/plain)
2014-08-13 11:13 UTC, Alexander Simon
Details
stacktrace (1.07 KB, text/plain)
2014-09-04 12:41 UTC, kosmonaffft
Details
stacktrace (1.07 KB, text/plain)
2014-09-23 18:04 UTC, Exceptions Reporter
Details
stacktrace (1.22 KB, text/plain)
2014-11-13 15:21 UTC, Alexander Simon
Details
stacktrace (1.22 KB, text/plain)
2015-01-16 01:00 UTC, tbrunhoff
Details
stacktrace (1.22 KB, text/plain)
2015-01-16 23:51 UTC, tbrunhoff
Details

Note You need to log in before you can comment on or make changes to this bug.
Description tbrunhoff 2014-04-29 17:27:15 UTC
Build: NetBeans IDE Dev (Build 201404290001)
VM: Java HotSpot(TM) Client VM, 24.51-b03, Java(TM) SE Runtime Environment, 1.7.0_51-b13
OS: Linux

User Comments:
tbrunhoff: starting a debug session.




Stacktrace: 
java.lang.Exception: resume without suspend 0
   at org.netbeans.modules.cnd.utils.CndUtils.severe(CndUtils.java:200)
   at org.netbeans.modules.cnd.utils.CndUtils.assertTrue(CndUtils.java:185)
   at org.netbeans.modules.cnd.modelimpl.platform.CsmEventListener.resume(CsmEventListener.java:167)
   at org.netbeans.modules.cnd.modelimpl.platform.CsmEventDispatcher$ItemListener.fileOperationsFinished(CsmEventDispatcher.java:470)
   at org.netbeans.modules.cnd.makeproject.NativeProjectProvider.fireFileOperationsFinished(NativeProjectProvider.java:371)
   at org.netbeans.modules.cnd.makeproject.api.ProjectActionSupport$FileOperationsNotifier.onFinish(ProjectActionSupport.java:299)
Comment 1 tbrunhoff 2014-04-29 17:27:16 UTC
Created attachment 147013 [details]
stacktrace
Comment 2 Alexander Simon 2014-07-22 12:28:28 UTC
Created attachment 148201 [details]
stacktrace

build project
Comment 3 Alexander Simon 2014-08-13 11:13:50 UTC
Created attachment 148676 [details]
stacktrace

rebuild simple application
Comment 4 kosmonaffft 2014-09-04 12:41:04 UTC
Created attachment 149036 [details]
stacktrace

Rebuild C++ project...
Comment 5 Exceptions Reporter 2014-09-16 18:09:07 UTC
This bug already has 5 duplicates 
see http://statistics.netbeans.org/exceptions/detail.do?id=209399
Comment 6 Exceptions Reporter 2014-09-23 18:04:50 UTC
Created attachment 149473 [details]
stacktrace

compile
Comment 7 Alexander Simon 2014-11-13 15:21:51 UTC
Created attachment 150469 [details]
stacktrace

build full remote project
Comment 8 tbrunhoff 2015-01-16 01:00:41 UTC
Created attachment 151533 [details]
stacktrace

project rebuild.
Comment 9 tbrunhoff 2015-01-16 23:51:41 UTC
Created attachment 151552 [details]
stacktrace

clean and build
Comment 10 Exceptions Reporter 2015-01-16 23:51:46 UTC
This bug already has 10 duplicates 
see http://statistics.netbeans.org/exceptions/detail.do?id=209399
Comment 11 Vladimir Kvashin 2015-09-23 22:13:54 UTC
More than 10 dups
Comment 12 Vladimir Voskresensky 2016-11-29 18:11:48 UTC
Alexander, please, help to investigate (add more logging and keep more stacks if needed)
Comment 13 Vladimir Voskresensky 2016-12-02 14:47:51 UTC
added extra logging on enum
changeset: 313601:33ab7a41d443 [release82] 
Let's wait for more information
Comment 14 Quality Engineering 2016-12-08 02:36:15 UTC
Integrated into 'main-silver', will be available in build *201612080001* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)

Changeset: http://hg.netbeans.org/main-silver/rev/222d78f18a3a
User: Vladimir Voskresensky <vv159170@netbeans.org>
Log: fixed #244180 - Exception: resume without suspend 0
- added extra logging to find out the reason of unpaired suspend/resume requests
(transplanted from 33ab7a41d44341da9d1ecda79903f86a249a19c0)
Comment 15 soldatov 2016-12-12 09:02:51 UTC
I can't reproduce this random exception in internal NetBeans 8,2 patch 1 build.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo