Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 243857 - Multiple cursor support
Multiple cursor support
Status: RESOLVED DUPLICATE of bug 200027
Product: editor
Classification: Unclassified
Component: Key bindings
8.0.1
All All
: P3 (vote)
: TBD
Assigned To: Svata Dedic
issues@editor
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2014-04-16 06:22 UTC by sandreas
Modified: 2014-04-28 15:21 UTC (History)
0 users

See Also:
Issue Type: ENHANCEMENT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description sandreas 2014-04-16 06:22:40 UTC
As seen in Sublimetext, it would be great to have a feature supporting multiple cursors in Netbeans.

Szenario:
- Press STRG while clicking any point in the editor window puts a marker on every clicked spot
- Editing Text via keyboard now inserts/updates/deletes the text on every marker like done in one single line but for multiple lines now
- In combination with a shortcut to mark all occurences (e.g. ALT+F3) this would be a really cool feature

Refer to following links for mor information:
https://www.youtube.com/watch?v=WXuBgSpLpK4&noredirect=1
http://stackoverflow.com/questions/14963775/multiple-cursors-in-sublime-text-2-windows
Comment 1 timharris777 2014-04-28 15:21:29 UTC
Marking as Duplicate

*** This bug has been marked as a duplicate of bug 200027 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo