Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 243529 - Add Scroll ability via mouse to Search Results, Output, Usages....
Add Scroll ability via mouse to Search Results, Output, Usages....
Status: RESOLVED FIXED
Product: platform
Classification: Unclassified
Component: Window System
8.0
PC Linux
: P3 (vote)
: 8.0.1
Assigned To: Stanislav Aubrecht
issues@platform
:
: 240830 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2014-04-03 14:47 UTC by tomzi
Modified: 2014-07-08 02:28 UTC (History)
1 user (show)

See Also:
Issue Type: ENHANCEMENT
:


Attachments
IDE log (128.68 KB, text/plain)
2014-04-03 14:47 UTC, tomzi
Details

Note You need to log in before you can comment on or make changes to this bug.
Description tomzi 2014-04-03 14:47:25 UTC
Currently only the main tab view, containing, source corde... is able to scroll through the tabs by using the mouse scroll wheel.

But other tabs don't have this support, like
Versioning Output, Search Results, Test Results, Output, Usages, ...

All those have support for multiple tabs and it would improve usability a lot if you could scroll through them via the mouse wheel


Product Version = NetBeans IDE 8.0 (Build 201403101706)
Operating System = Linux version 3.5.0-47-generic running on amd64
Java; VM; Vendor = 1.7.0_51
Runtime = Java HotSpot(TM) 64-Bit Server VM 24.51-b03
Comment 1 tomzi 2014-04-03 14:47:28 UTC
Created attachment 146525 [details]
IDE log
Comment 2 tomzi 2014-04-03 14:48:51 UTC
The current method of scrolling use the tiny weeny arrows is really not very user friendly :)
Comment 3 Stanislav Aubrecht 2014-07-03 14:33:14 UTC
*** Bug 240830 has been marked as a duplicate of this bug. ***
Comment 4 Stanislav Aubrecht 2014-07-07 14:00:28 UTC
core-main ad961092b831
Comment 5 Quality Engineering 2014-07-08 02:28:45 UTC
Integrated into 'main-silver', will be available in build *201407080001* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)

Changeset: http://hg.netbeans.org/main-silver/rev/ad961092b831
User: S. Aubrecht <saubrecht@netbeans.org>
Log: #243529 - mouse wheel scrolling of inner tabs in Output, Search Results and Usages windows


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo