Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 243134 - webkit embeded browser black window
webkit embeded browser black window
Status: RESOLVED DUPLICATE of bug 236961
Product: platform
Classification: Unclassified
Component: Embedded Browser
8.0
PC Linux
: P3 (vote)
: TBD
Assigned To: Stanislav Aubrecht
issues@platform
https://netbeans.org/bugzilla/show_bu...
: REGRESSION, USABILITY
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2014-03-21 10:23 UTC by sorinn
Modified: 2014-03-21 20:12 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
IDE log (462.07 KB, text/plain)
2014-03-21 10:23 UTC, sorinn
Details

Note You need to log in before you can comment on or make changes to this bug.
Description sorinn 2014-03-21 10:23:54 UTC
Product Version = NetBeans IDE 8.0 (Build 201403101706)
Operating System = Linux version 3.11.0-18-generic running on i386
Java; VM; Vendor = 1.8.0
Runtime = Java HotSpot(TM) Client VM 25.0-b70


Netbeans 8 (HTML and PHP version) come unusable for webdevelopers who want a quick check of their scripts

Usually webdevelopers keep few windows / browsers opened at the same time - so the embedded webkit preview is used for the small quick checks 

Not always you need to check the whole project in a browser window - therefore the embedded preview come as an important tool for us. 

in 7.4 this was fixed - but in 8.0 this bug is back - so we have to stick with 7.4 until is fixed. 

I've do my research and I discovered that this bug is desctibed here : https://netbeans.org/bugzilla/show_bug.cgi?id=236961

..hope it helps
Comment 1 sorinn 2014-03-21 10:23:59 UTC
Created attachment 146215 [details]
IDE log
Comment 2 sorinn 2014-03-21 10:34:36 UTC
the workaround presented here is made for peoples using jQuery lib 

if you do not use jQuery on your project, use this code at the end of your file you want to check : 

<script>

        function hideNetbeansGlassPane()
        {
            document.getElementById('netbeans_glasspane'').remove();
        }
        setTimeout(hideNetbeansGlassPane, 500);

</script>
Comment 3 sorinn 2014-03-21 10:37:12 UTC
I forgot to mention the link for the previous workaround ( from: https://netbeans.org/bugzilla/show_bug.cgi?id=236961 )

the original text : 

websafe 2013-12-19 16:35:38 UTC
I'm on Linux with Nvidia too, but I think this is not Nvidia related. The problem is caused by the canvas added at the end of the previewed html.

Currently I'm using a quick workaround, I' just added this code:

~~~~ html
<script>
    $(document).ready(function(){
        function hideNetbeansGlassPane() {
            $('#netbeans_glasspane').remove();
        }
        setTimeout(hideNetbeansGlassPane, 500);
    });
</script>
~~~~

at the end of HTML generated by the app I'm working on. It's basically about hiding `<canvas id="netbeans_glasspane" ...` which is added at the end of generated HTML (You can see this right click on browser -> dump document).
Canvas needs to be destroyed/hidden after a small delay. Directly on `.ready` without a delay will not work as expected.

http://devlog.websafe.pl/2013/12/19/black-screen-netbeans-embedded-webkit-browser-workaround/
Comment 4 Vladimir Riha 2014-03-21 11:30:41 UTC
Why are you opening another issue with the same problem if you found the older one? Isn't this a dupl. of the issue 236961 ? Could you instead add informationVidean to that issue (e.g. if you have nVidia graphic card)? 

Removing the canvas breaks some web inspection features and NetBeans uses canvas to highlight elements on page.
Comment 5 Vladimir Riha 2014-03-21 20:12:51 UTC

*** This bug has been marked as a duplicate of bug 236961 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo