Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 243086 - java.lang.AssertionError: org.xml.sax.SAXParseException
java.lang.AssertionError: org.xml.sax.SAXParseException
Status: RESOLVED WORKSFORME
Product: webservices
Classification: Unclassified
Component: JAX-WS
8.0
PC Windows 8
: P2 with 1 vote (vote)
: TBD
Assigned To: Milan Kuchtiak
issues@webservices
: JDK_8
: 241456 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2014-03-20 12:37 UTC by dunis
Modified: 2014-06-06 15:59 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
IDE log (69.74 KB, text/plain)
2014-03-20 12:37 UTC, dunis
Details

Note You need to log in before you can comment on or make changes to this bug.
Description dunis 2014-03-20 12:37:25 UTC
Product Version = NetBeans IDE 8.0 (Build 201403101706)
Operating System = Windows 8 version 6.2 running on amd64
Java; VM; Vendor = 1.8.0
Runtime = Java HotSpot(TM) 64-Bit Server VM 25.0-b70
Grave:   service exception:
java.lang.AssertionError: org.xml.sax.SAXParseException; systemId: bundle://218.0:1/com/sun/tools/xjc/reader/xmlschema/bindinfo/binding.xsd; lineNumber: 52; columnNumber: 88; schema_reference: fallo al leer el documento de esquema 'xjc.xsd' porque no se permite el acceso 'bundle' debido a una restricción definida por la propiedad accessExternalSchema. 
	at com.sun.tools.xjc.SchemaCache.newValidator(SchemaCache.java:80)
	at com.sun.tools.xjc.reader.internalizer.SCDBasedBindingSet.apply(SCDBasedBindingSet.java:237)
	at com.sun.tools.xjc.ModelLoader.createXSOM(ModelLoader.java:541)
	at com.sun.tools.xjc.api.impl.s2j.SchemaCompilerImpl.bind(SchemaCompilerImpl.java:269)
	at com.sun.tools.xjc.api.impl.s2j.SchemaCompilerImpl.bind(SchemaCompilerImpl.java:95)
	at com.sun.tools.ws.processor.modeler.wsdl.JAXBModelBuilder.bind(JAXBModelBuilder.java:142)
	at com.sun.tools.ws.processor.modeler.wsdl.WSDLModeler.buildJAXBModel(WSDLModeler.java:2298)
	at com.sun.tools.ws.processor.modeler.wsdl.WSDLModeler.internalBuildModel(WSDLModeler.java:198)
	at com.sun.tools.ws.processor.modeler.wsdl.WSDLModeler.buildModel(WSDLModeler.java:141)
	at com.sun.tools.ws.wscompile.WsimportTool.buildWsdlModel(WsimportTool.java:444)
	at com.sun.tools.ws.wscompile.WsimportTool.run(WsimportTool.java:205)
	at com.sun.tools.ws.wscompile.WsimportTool.run(WsimportTool.java:183)
	at com.sun.tools.ws.util.WSToolsObjectFactoryImpl.wsimport(WSToolsObjectFactoryImpl.java:60)
	at com.sun.tools.ws.spi.WSToolsObjectFactory.wsimport(WSToolsObjectFactory.java:88)
	at org.glassfish.webservices.monitoring.WebServiceTesterServlet.wsImport(WebServiceTesterServlet.java:642)
	at org.glassfish.webservices.monitoring.WebServiceTesterServlet.initializePort(WebServiceTesterServlet.java:528)
	at org.glassfish.webservices.monitoring.WebServiceTesterServlet.doGet(WebServiceTesterServlet.java:169)
	at org.glassfish.webservices.monitoring.WebServiceTesterServlet.invoke(WebServiceTesterServlet.java:104)
	at org.glassfish.webservices.EjbWebServiceServlet.service(EjbWebServiceServlet.java:136)
	at javax.servlet.http.HttpServlet.service(HttpServlet.java:790)
	at org.glassfish.grizzly.servlet.ServletHandler.doServletService(ServletHandler.java:242)
	at org.glassfish.grizzly.servlet.ServletHandler.service(ServletHandler.java:193)
	at com.sun.enterprise.v3.services.impl.ContainerMapper.service(ContainerMapper.java:246)
	at org.glassfish.grizzly.http.server.HttpHandler.runService(HttpHandler.java:191)
	at org.glassfish.grizzly.http.server.HttpHandler.doHandle(HttpHandler.java:168)
	at org.glassfish.grizzly.http.server.HttpServerFilter.handleRead(HttpServerFilter.java:189)
	at org.glassfish.grizzly.filterchain.ExecutorResolver$9.execute(ExecutorResolver.java:119)
	at org.glassfish.grizzly.filterchain.DefaultFilterChain.executeFilter(DefaultFilterChain.java:288)
	at org.glassfish.grizzly.filterchain.DefaultFilterChain.executeChainPart(DefaultFilterChain.java:206)
	at org.glassfish.grizzly.filterchain.DefaultFilterChain.execute(DefaultFilterChain.java:136)
	at org.glassfish.grizzly.filterchain.DefaultFilterChain.process(DefaultFilterChain.java:114)
	at org.glassfish.grizzly.ProcessorExecutor.execute(ProcessorExecutor.java:77)
	at org.glassfish.grizzly.nio.transport.TCPNIOTransport.fireIOEvent(TCPNIOTransport.java:838)
	at org.glassfish.grizzly.strategies.AbstractIOStrategy.fireIOEvent(AbstractIOStrategy.java:113)
	at org.glassfish.grizzly.strategies.WorkerThreadIOStrategy.run0(WorkerThreadIOStrategy.java:115)
	at org.glassfish.grizzly.strategies.WorkerThreadIOStrategy.access$100(WorkerThreadIOStrategy.java:55)
	at org.glassfish.grizzly.strategies.WorkerThreadIOStrategy$WorkerThreadRunnable.run(WorkerThreadIOStrategy.java:135)
	at org.glassfish.grizzly.threadpool.AbstractThreadPool$Worker.doWork(AbstractThreadPool.java:564)
	at org.glassfish.grizzly.threadpool.AbstractThreadPool$Worker.run(AbstractThreadPool.java:544)
	at java.lang.Thread.run(Thread.java:744)
Caused by: org.xml.sax.SAXParseException; systemId: bundle://218.0:1/com/sun/tools/xjc/reader/xmlschema/bindinfo/binding.xsd; lineNumber: 52; columnNumber: 88; schema_reference: fallo al leer el documento de esquema 'xjc.xsd' porque no se permite el acceso 'bundle' debido a una restricción definida por la propiedad accessExternalSchema. 
	at com.sun.org.apache.xerces.internal.util.ErrorHandlerWrapper.createSAXParseException(ErrorHandlerWrapper.java:203)
	at com.sun.org.apache.xerces.internal.util.ErrorHandlerWrapper.fatalError(ErrorHandlerWrapper.java:177)
	at com.sun.org.apache.xerces.internal.impl.XMLErrorReporter.reportError(XMLErrorReporter.java:441)
	at com.sun.org.apache.xerces.internal.impl.xs.traversers.XSDHandler.reportSchemaErr(XSDHandler.java:4162)
	at com.sun.org.apache.xerces.internal.impl.xs.traversers.XSDHandler.reportSchemaFatalError(XSDHandler.java:4141)
	at com.sun.org.apache.xerces.internal.impl.xs.traversers.XSDHandler.getSchemaDocument(XSDHandler.java:2168)
	at com.sun.org.apache.xerces.internal.impl.xs.traversers.XSDHandler.resolveSchema(XSDHandler.java:2078)
	at com.sun.org.apache.xerces.internal.impl.xs.traversers.XSDHandler.constructTrees(XSDHandler.java:1008)
	at com.sun.org.apache.xerces.internal.impl.xs.traversers.XSDHandler.parseSchema(XSDHandler.java:620)
	at com.sun.org.apache.xerces.internal.impl.xs.XMLSchemaLoader.loadSchema(XMLSchemaLoader.java:616)
	at com.sun.org.apache.xerces.internal.impl.xs.XMLSchemaLoader.loadGrammar(XMLSchemaLoader.java:574)
	at com.sun.org.apache.xerces.internal.impl.xs.XMLSchemaLoader.loadGrammar(XMLSchemaLoader.java:540)
	at com.sun.org.apache.xerces.internal.jaxp.validation.XMLSchemaFactory.newSchema(XMLSchemaFactory.java:255)
	at javax.xml.validation.SchemaFactory.newSchema(SchemaFactory.java:638)
	at javax.xml.validation.SchemaFactory.newSchema(SchemaFactory.java:670)
	at com.sun.tools.xjc.SchemaCache.newValidator(SchemaCache.java:77)
	... 39 more
Comment 1 dunis 2014-03-20 12:37:31 UTC
Created attachment 146173 [details]
IDE log
Comment 2 Kenneth Ganfield 2014-04-02 13:57:22 UTC
Product Version: NetBeans IDE 8.0 (Build 201403101706)
Java: 1.8.0; Java HotSpot(TM) 64-Bit Server VM 25.0-b70
Runtime: Java(TM) SE Runtime Environment 1.8.0-b132
System: Mac OS X version 10.8.5 running on x86_64; UTF-8; en_US (nb)
Comment 3 dunis 2014-04-02 22:25:56 UTC
after thrown exception will test a url of my application with webservices java 7 have no problems in testing but do java8 is impossible to test for safety reasons.
Comment 4 Kenneth Ganfield 2014-04-03 15:05:42 UTC
Created FAQ that describes how to disable restriction on accessing external schema:

http://wiki.netbeans.org/FaqWSDLExternalSchema
Comment 5 dunis 2014-04-03 19:12:12 UTC
follow this reading but as usual solved nothing in me keeps coming netbeans 8 poster warning unable to open webservices tester page
Comment 6 Kenneth Ganfield 2014-04-03 20:02:07 UTC
When I add the jvm argument to the domain.xml file and restart the server I am able to launch the web service tester page from the IDE.
Comment 7 dunis 2014-04-04 03:17:32 UTC
hello again, 
is impossible not to walk the offered solution, working with windows 8.1 and java_8, that hurts.
Comment 8 dunis 2014-04-06 13:18:32 UTC
hello, java8 solved with netbeans8 I did was install glassfish 4.0.1 using the last upgrade of webservices jersey, and now run the webservices tester, thanks for the feedback.
Comment 9 Milan Kuchtiak 2014-04-28 08:48:53 UTC
Hello,

Is that something on Netbeans side that should be fixed ?

Seems that the JVM argument, described in http://wiki.netbeans.org/FaqWSDLExternalSchema helped.
Comment 10 dunis 2014-04-28 11:45:51 UTC
Hi this error as I described in previous post was when just came out and I wanted to try java8 webservices (test), and changing netbeans8 accessExternalSchema in glassfish 4.0 was still the same error, at the end I upgraded to 4.0.1 and glassfish greetings corrected. -
Comment 11 Milan Kuchtiak 2014-04-28 12:09:52 UTC
Hi did you do the same modification if domain.xml on GlassFish 4.0 (as on GlassFish 4.0.1) ?

Are you saying that JAX-WS services don't work on GlassFish 4.0 (and JDK8) even when accessExternalSchema property is set in domain.xml ?
Comment 12 dunis 2014-04-28 13:38:19 UTC
hi, if it is a friend so at least I spent my, he tried everything, by code, in glassfish jvm option in domain.xml in java policy (security), etc.. When he left the 4.0.1 upgrade, see http://www.adam-bien.com/roller/abien/entry/glassfish_v4_0_1_daily 

Then I could apply this patch do test webservices in browser correctly, greetings and good morning.
Comment 13 Milan Kuchtiak 2014-05-23 07:36:40 UTC
I am afraid there is nothing we can do from Netbeans site.
The instructions on Netbeans Wiki help to resolve the issue, that arised in jdk8:
http://wiki.netbeans.org/FaqWSDLExternalSchema
Comment 14 Milan Kuchtiak 2014-05-23 07:40:46 UTC
*** Bug 241456 has been marked as a duplicate of this bug. ***
Comment 15 anfelipe 2014-06-06 15:59:15 UTC
Hi, I had this same issue with Netbeans 8.0 and JDK 8, I just wanted to say that this faq http://wiki.netbeans.org/FaqWSDLExternalSchema solved my problem, thanks.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo