Bug 242920 - Refactoring is broken for classes using project lombok
Refactoring is broken for classes using project lombok
Status: RESOLVED DUPLICATE of bug 236885
Product: editor
Classification: Unclassified
Component: Refactoring
8.0
PC Windows 7 x64
: P3 with 1 vote (vote)
: TBD
Assigned To: Ralph Ruijs
issues@editor
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2014-03-15 10:36 UTC by thpe
Modified: 2014-03-15 14:05 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description thpe 2014-03-15 10:36:52 UTC
The following refactoring actions are broken if a class uses a lombok annotation: 
* rename of a class
* rename of a variable
* change of method parameters

I didn't tried the remainder of the refactorings. 


Tested with: 
* Netbeans 8.0 RC1
* Lombok 1.12.4

Steps to reproduce: 
* File =>New Project => Maven => new Java Application
* Modify Pom with the following dependency

<dependency>
  <groupId>org.projectlombok</groupId>
  <artifactId>lombok</artifactId>
  <version>1.12.4</version>
</dependency>

* Create a Pojo, use for example the @Data Annotation (applies for all lombok annotations so far)
* hit refactoring

Usually it doubles the class and sometimes the refactored and unrefactored parts of the class are tangled and messed up. 

a related Bug report in lombok can be found at https://code.google.com/p/projectlombok/issues/detail?id=106
Comment 1 thpe 2014-03-15 14:05:00 UTC

*** This bug has been marked as a duplicate of bug 236885 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo