Bug 242779 - Inspection does not start with Cordova 3.4.0-0.1.3 on iOS device
Inspection does not start with Cordova 3.4.0-0.1.3 on iOS device
Status: VERIFIED FIXED
Product: web
Classification: Unclassified
Component: Cordova
8.0
PC Linux
: P2 (vote)
: 8.0
Assigned To: Jan Becicka
issues@web
80patch1-verified
:
: 242783 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2014-03-11 09:03 UTC by Vladimir Riha
Modified: 2014-08-06 15:06 UTC (History)
3 users (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Vladimir Riha 2014-03-11 09:03:04 UTC
I've tried maybe 10 times, inspection does not start. After installing older Cordova 3.3.0-0.1.1, it works like a charm.


Product Version: NetBeans IDE 8.0 (Build 201403101706)
JDK8
Comment 1 Vladimir Riha 2014-03-13 08:59:53 UTC
This is could be caused by issue 242783. 

With Cordova 3.3, file platforms/ios/[application name]/config.xml contains ID attribute of root element <widget> and it is set to the Application ID configured in project properties. 

With Cordova 3.4.0-0.1.3, this ID attribute contains always the com.coolappz.[application name]. 

I tried to change build.xml file and replaced all occurrences of com.coolappz with proper values but that didn't change anything, config.xml was again created with wrong ID attribute. And config.xml was then re-created on run as well... My guess is that since this the ID does not match my developer certificate, web inspection cannot work.
Comment 2 Vladimir Riha 2014-03-13 10:23:22 UTC
I propose release note:

Description: Debugging on iOS target does not start with Cordova 3.4.0-0.1.3. because of incorrect package and application name used to build the project
Workaround: Install Cordova 3.3.0-0.1.1 instead using command 'npm install -g cordova@3.3.0-0.1.1
Comment 3 Jan Becicka 2014-03-21 07:56:36 UTC
*** Bug 242783 has been marked as a duplicate of this bug. ***
Comment 4 Jan Becicka 2014-03-21 09:39:46 UTC
Changeset: 3edde523e50e
Author:    Jan Becicka <jbecicka@netbeans.org>
Date:      2014-03-21 10:34
Message:
Comment 5 Quality Engineering 2014-03-22 07:30:02 UTC
Integrated into 'main-silver', will be available in build *201403220001* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)

Changeset: http://hg.netbeans.org/main-silver/rev/3edde523e50e
User: Jan Becicka <jbecicka@netbeans.org>
Log: Issue #242779 - Inspection does not start with Cordova 3.4.0-0.1.3 on iOS device
Comment 6 Vladimir Riha 2014-04-16 12:46:21 UTC
Thank you, verified

Product Version: NetBeans IDE Dev (Build 201404160001)
Java: 1.8.0_05; Java HotSpot(TM) 64-Bit Server VM 25.5-b02
Runtime: Java(TM) SE Runtime Environment 1.8.0_05-b13
System: Mac OS X version 10.9.2 running on x86_64; UTF-8; en_US (nb)
Comment 7 Jan Becicka 2014-04-18 13:19:40 UTC
changeset:   282782:3fb6d269db60
branch:      release80
user:        Jan Becicka <jbecicka@netbeans.org>
date:        Fri Mar 21 10:34:31 2014 +0100
summary:     Issue #242779 - Inspection does not start with Cordova 3.4.0-0.1.3 on iOS device
Comment 8 Quality Engineering 2014-04-24 02:09:20 UTC
Integrated into 'releases/release80', will be available in build *201404240045* or newer. Wait for official and publicly available build.

Changeset: http://hg.netbeans.org/releases/rev/3fb6d269db60
User: Jan Becicka <jbecicka@netbeans.org>
Log: Issue #242779 - Inspection does not start with Cordova 3.4.0-0.1.3 on iOS device
Comment 9 Vladimir Riha 2014-04-28 10:50:05 UTC
verified in patch1


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo