Bug 242544 - IllegalArgumentException: #177688: property editor org.openide.explorer.propertysheet.PropUtils$NoPropertyEditorEditor@198af127 for property org.apache.tools.ant.module.AntCustomizer$2[name=properties
IllegalArgumentException: #177688: property editor org.openide.explorer.prope...
Status: RESOLVED DUPLICATE of bug 209598
Product: platform
Classification: Unclassified
Component: Property Sheet
8.0
All All
: P3 (vote)
: TBD
Assigned To: Stanislav Aubrecht
issues@platform
EXCEPTIONS_REPORT
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2014-03-04 10:36 UTC by Exceptions Reporter
Modified: 2014-03-21 09:16 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
stacktrace (5.18 KB, text/plain)
2014-03-04 10:36 UTC, Exceptions Reporter
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Exceptions Reporter 2014-03-04 10:36:52 UTC
This bug was originally marked as duplicate of bug 209598, that is already resolved. This bug is still valid, so this seems to be another bug, but it might be related.

Build: IFS Developer Studio 8.72.97.2742 (built 20140224-1152)
VM: Java HotSpot(TM) 64-Bit Server VM, 23.25-b01, Java(TM) SE Runtime Environment, 1.7.0_25-b17
OS: Windows 7

User Comments:
GUEST: Estaba ejecutando Main




Stacktrace: 
java.lang.IllegalArgumentException: #177688: property editor org.openide.explorer.propertysheet.PropUtils$NoPropertyEditorEditor@198af127 for property org.apache.tools.ant.module.AntCustomizer$2[name=properties] does not support a custom editor; valueType=java.util.Properties; PropertyEditorManager says: null; search path is: [sun.beans.editors]; CCL: SystemClassLoader[503 modules]
   at org.openide.explorer.propertysheet.CustomEditorDisplayer.setPropertyEditor(CustomEditorDisplayer.java:149)
   at org.openide.explorer.propertysheet.CustomEditorDisplayer.getPropertyEditor(CustomEditorDisplayer.java:128)
   at org.openide.explorer.propertysheet.CustomEditorDisplayer.getCustomEditor(CustomEditorDisplayer.java:119)
   at org.openide.explorer.propertysheet.CustomEditorDisplayer.getComponent(CustomEditorDisplayer.java:352)
   at org.openide.explorer.propertysheet.PropertyPanel.installDisplayerComponent(PropertyPanel.java:492)
   at org.openide.explorer.propertysheet.PropertyPanel.addNotify(PropertyPanel.java:735)
Comment 1 Exceptions Reporter 2014-03-04 10:36:54 UTC
Created attachment 145743 [details]
stacktrace
Comment 2 Stanislav Aubrecht 2014-03-21 09:16:18 UTC
IFS Developer Studio seems to be built from NetBeans modules dated 20120717. Please reopen if reproducible with the latest version of NetBeans platform, thanks.

*** This bug has been marked as a duplicate of bug 209598 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo