Bug 24243 - Complete the API documentation
Complete the API documentation
Status: CLOSED FIXED
Product: usersguide
Classification: Unclassified
Component: Projects
3.x
PC Windows 3.1/NT
: P1 (vote)
: 3.x
Assigned To: Pavel Buzek
issues@projects
:
: 20213 (view as bug list)
Depends on:
Blocks: 20213
  Show dependency treegraph
 
Reported: 2002-05-30 12:50 UTC by Pavel Buzek
Modified: 2003-12-11 14:25 UTC (History)
0 users

See Also:
Issue Type: TASK
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Pavel Buzek 2002-05-30 12:50:28 UTC
Currently the API documentation only covers the parts of design which are finished, for the rest 
of the features it is hard to find a proposal, design spec. or just a decision written in emails. For 
a better orientation of module developers make the documentation complete in the sence that 
it would cover all features and areas planned for 4.0. Some of them can be unfinished but need 
at least to be mentioned.
Comment 1 Pavel Buzek 2002-06-06 15:52:33 UTC
few notes for myself (what should be added):
1. overview (what can be customized by modules):
http://projects.netbeans.org/servlets/ReadMsg?msgId=327201&listName=dev
2. what will be changed/incomatible:
http://projects.netbeans.org/servlets/ReadMsg?msgId=324640&listName=dev
3. wizards and temlpates
4. how to implement resources and outputs (api, hints, examples)
5. how to implement nested projects (hints, examples)
6. configurations
7. private settings
8. term: project nature
http://projects.netbeans.org/servlets/ReadMsg?msgId=328807&listName=dev
Comment 3 Pavel Buzek 2002-07-01 09:50:40 UTC
started, draft document can be found in CVS in projects module, \api\doc\dev_guide.html in 
prj40_prototype branch.
Comment 4 Pavel Buzek 2002-07-18 14:09:11 UTC
an example of a simple howto:
http://projects.netbeans.org/servlets/ReadMsg?msgId=346736&listName=dev
Comment 5 Pavel Buzek 2002-07-26 11:11:37 UTC
*** Issue 20213 has been marked as a duplicate of this issue. ***
Comment 6 Pavel Buzek 2002-07-26 13:14:38 UTC
needs to be completed for M3
Comment 7 Pavel Buzek 2002-07-30 13:20:31 UTC
Must-have features for milestone3, have impact on APIs (at least potential).
Comment 8 Pavel Buzek 2002-11-08 09:25:40 UTC
the docs are completed. they must of course be updated whenever we make changes/additions to APIs.
Comment 9 Pavel Buzek 2003-07-02 10:21:16 UTC
done, closing


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo