Bug 242422 - NullPointerException at org.netbeans.modules.refactoring.java.plugins.PullUpTransformer.addAbstractMemberToTarget
NullPointerException at org.netbeans.modules.refactoring.java.plugins.PullUpT...
Status: RESOLVED DUPLICATE of bug 236885
Product: java
Classification: Unclassified
Component: Refactoring
8.0
All All
: P3 (vote)
: 8.0.1
Assigned To: Ralph Ruijs
issues@java
EXCEPTIONS_REPORT
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2014-02-27 15:57 UTC by Michel Graciano
Modified: 2014-07-15 12:25 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments
stacktrace (3.93 KB, text/plain)
2014-02-27 15:57 UTC, Michel Graciano
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Michel Graciano 2014-02-27 15:57:24 UTC
Build: NetBeans IDE Dev (Build 20140227-8aabb71e3f6d)
VM: Java HotSpot(TM) 64-Bit Server VM, 24.0-b56, Java(TM) SE Runtime Environment, 1.7.0_40-b43
OS: Linux

User Comments:
hmichel: Pull Up some methods to a interface (Lombok active)




Stacktrace: 
java.lang.NullPointerException
   at org.netbeans.modules.refactoring.java.plugins.PullUpTransformer.addAbstractMemberToTarget(PullUpTransformer.java:173)
   at org.netbeans.modules.refactoring.java.plugins.PullUpTransformer.addMembersToTarget(PullUpTransformer.java:125)
   at org.netbeans.modules.refactoring.java.plugins.PullUpTransformer.visitClass(PullUpTransformer.java:106)
   at org.netbeans.modules.refactoring.java.plugins.PullUpTransformer.visitClass(PullUpTransformer.java:81)
   at com.sun.tools.javac.tree.JCTree$JCClassDecl.accept(JCTree.java:719)
   at com.sun.source.util.TreePathScanner.scan(TreePathScanner.java:68)
Comment 1 Michel Graciano 2014-02-27 15:57:29 UTC
Created attachment 145638 [details]
stacktrace
Comment 2 Ralph Ruijs 2014-07-15 12:25:09 UTC

*** This bug has been marked as a duplicate of bug 236885 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo