Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 242183 - [80cat]Deploying EAR project does not create JNDI resources
[80cat]Deploying EAR project does not create JNDI resources
Status: RESOLVED FIXED
Product: serverplugins
Classification: Unclassified
Component: GlassFish
8.0
PC All
: P3 (vote)
: 8.1
Assigned To: Petr Hejl
issues@serverplugins
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2014-02-21 08:24 UTC by manikantannaren
Modified: 2015-05-20 12:18 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments
Glassfish Stack trace on deploying the ear (48.59 KB, text/plain)
2014-02-21 08:27 UTC, manikantannaren
Details

Note You need to log in before you can comment on or make changes to this bug.
Description manikantannaren 2014-02-21 08:24:44 UTC
https://netbeans.org/kb/docs/javaee/maven-entapp.html

As per the tutorial, on running the application, the neccessary JNDI resources are created if not present (When you click Run the IDE will deploy the EAR archive and create the JMS resources on the server)

But that did not happen. I had to manually create the resources on Glassfish to be to able to successfully run the project.
Comment 1 manikantannaren 2014-02-21 08:27:14 UTC
Created attachment 145459 [details]
Glassfish Stack trace on deploying the ear
Comment 2 manikantannaren 2014-03-07 05:44:01 UTC
Happens with both Maven or Ant based project types.
Comment 3 Petr Hejl 2015-05-12 11:09:29 UTC
What GF and IDE version do you use?
Comment 4 Petr Hejl 2015-05-15 08:57:50 UTC
Reproducible.
Comment 5 Petr Hejl 2015-05-19 11:15:14 UTC
The specification says that "By default, environment entries declared by application components are created in the java:comp/env namespace." So the destination lookup generated for JMS defined by annotation is wrong. For JMS the reasonable default used by the IDE would be java:global or java:app imo.
Comment 6 Petr Hejl 2015-05-19 14:07:28 UTC
The JMS queue is generated with java:app prefix now - web-main 53b5c62db629. I need to verify the tutorial and possibly file an issue for doc team.
Comment 7 Quality Engineering 2015-05-20 02:10:50 UTC
Integrated into 'main-silver', will be available in build *201505200001* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)

Changeset: http://hg.netbeans.org/main-silver/rev/53b5c62db629
User: Petr Hejl <phejl@netbeans.org>
Log: #242183 - [80cat]Deploying EAR project does not create JNDI resources
Comment 8 Petr Hejl 2015-05-20 12:18:21 UTC
Closing as fixed. There is a separate bug #252502 for the tutorial.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo