Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 24183 - runide.exe -? and -help show different help
runide.exe -? and -help show different help
Status: VERIFIED FIXED
Product: platform
Classification: Unclassified
Component: -- Other --
3.x
All All
: P3 (vote)
: 3.x
Assigned To: _ ttran
issues@platform
:
: 13515 (view as bug list)
Depends on:
Blocks: 32053
  Show dependency treegraph
 
Reported: 2002-05-29 10:55 UTC by iformanek
Modified: 2008-12-22 22:38 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description iformanek 2002-05-29 10:55:33 UTC
if "runide.exe -?" is executed, it displays some command-
line parameters on the console, whereas "runide.exe -help" 
opens a dialog describing some other command-line options. 
Perhaps those 2 should be merged into one set of options 
and one way of displaying them.
Comment 1 _ ttran 2002-06-04 06:36:36 UTC
-> ttran
Comment 2 _ ttran 2002-06-14 08:29:36 UTC
subcomp: documentation -> code.
Comment 3 Marek Grummich 2002-07-22 08:31:46 UTC
Target milestone was changed from '3.4' to TBD.
Comment 4 Marek Grummich 2002-07-22 08:38:41 UTC
Target milestone was changed from '3.4' to TBD.
Comment 5 Marek Grummich 2002-07-22 08:56:41 UTC
Target milestone was changed from '3.4' to TBD.
Comment 6 Marek Grummich 2002-07-22 09:01:33 UTC
Target milestone was changed from '3.4' to TBD.
Comment 7 Marek Grummich 2002-07-22 09:02:35 UTC
Target milestone was changed from '3.4' to TBD.
Comment 8 Marek Grummich 2002-07-22 09:06:27 UTC
Target milestone was changed from '3.4' to TBD.
Comment 9 Jesse Glick 2003-03-01 03:30:37 UTC
Note that as of 3.5, the runide.sh Unix launcher tells you how to get
the IDE help, and the IDE help tells you how to get the launcher help
(which works with the same param for both launchers). So it is not so
bad now.

It would be possible to merge these together in the launcher, though a
bit less maintainable since several params are interpreted in Java
code and it is easier to ensure that they are kept up-to-date there.
Comment 10 Jesse Glick 2003-03-01 03:31:53 UTC
*** Issue 13515 has been marked as a duplicate of this issue. ***
Comment 11 _ ttran 2004-01-10 00:02:06 UTC
fixed as a side effect the impl of issue 32053.
Comment 12 Marian Mirilovic 2005-07-13 13:23:59 UTC
closed


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo