Bug 24145 - Do not recommend lib/ext/ for drivers
Do not recommend lib/ext/ for drivers
Status: CLOSED FIXED
Product: db
Classification: Unclassified
Component: Code
3.x
PC Linux
: P3 (vote)
: 3.x
Assigned To: Radko Najman
issues@db
http://db.netbeans.org/doc/faq.html
: ARCH
: 34576 (view as bug list)
Depends on: 20663
Blocks: 29833 36163
  Show dependency treegraph
 
Reported: 2002-05-28 16:12 UTC by Jesse Glick
Modified: 2004-08-19 09:17 UTC (History)
4 users (show)

See Also:
Issue Type: TASK
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jesse Glick 2002-05-28 16:12:45 UTC
I think there is no longer any need to recommend
to users that new JDBC drivers be put on the
classpath - at least, not in NB 3.4, I am not sure
about 3.3. Try putting drivers in

modules/patches/org-netbeans-modules/db/

You can put a README.txt in that dir in
db/release/ to make it easier for users (cf. ant
module). This will put the drivers in the module
classloader for the DB module.

In NB 3.4, acc. to issue #20663, this will also
make them available in the context classloader for
all threads. That may be enough to have the
drivers be used anywhere in the system, without
affecting the classpath.

Also in the FAQ is says you can use $CLASSPATH
instead of lib/ext/. This is not true, I think;
$CLASSPATH is ignored by the launcher.
Comment 1 Marek Grummich 2002-07-22 08:49:01 UTC
Set target milestone to TBD
Comment 2 Radko Najman 2003-01-10 11:22:16 UTC
The driver registration will be changed. It wil be possible to
register a JDBC driver on the fly, without restarting the IDE, and it
will be not necessary to put the driver file into lib/ext directory.
Comment 3 Jesse Glick 2003-01-10 13:05:40 UTC
Good news!
Comment 4 Jesse Glick 2003-01-10 13:06:12 UTC
Martin, FYI.
Comment 5 Radko Najman 2003-06-25 10:08:54 UTC
*** Issue 34576 has been marked as a duplicate of this issue. ***
Comment 6 Radko Najman 2003-10-13 17:42:18 UTC
UI specification
http://db.netbeans.org/uispecs/db_jdbc_driver_manager.html
Comment 7 _ rkubacki 2003-11-18 15:00:58 UTC
I guess this should be at least P2 as it blocks P2. Also there is no
target milestone set. 
Comment 8 Jesse Glick 2003-11-18 15:26:24 UTC
Yes, need at least promo-D target milestone.
Comment 9 Radko Najman 2003-12-12 18:16:48 UTC
New registration of the JDBC drivers was implemented. For more info see:
http://db.netbeans.org/doc/jdbc_registration.html
http://db.netbeans.org/uispecs/db_jdbc_driver_manager.html
Comment 10 dmladek 2004-08-19 09:17:56 UTC
OK


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo