Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 241082 - "Track locations of component hierarchy changes" can cause sever slowdown for JavaFX apps.
"Track locations of component hierarchy changes" can cause sever slowdown for...
Status: RESOLVED FIXED
Product: debugger
Classification: Unclassified
Component: Java
8.0
PC Windows 7
: P2 (vote)
: 8.1
Assigned To: Martin Entlicher
issues@debugger
: 8.0_WAIVER_APPROVED, UI
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2014-01-28 21:29 UTC by swpalmer
Modified: 2015-08-23 01:22 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description swpalmer 2014-01-28 21:29:44 UTC
I forst noticed this in NetBeans 7.4 and confirmed it is still an issue as of 
NB dev build 20140120...

When the "Track locations of component hierarchy changes" option for "Visual Debugging" is selected performance for JavaFX applications that modify the scene graph can slow to a crawl.

Tools -> Options -> Java -> Java Debugger -> Visual Debugging
"Track locations of component hierarchy changes".

See discussion on NetCat email list here:
https://netbeans.org/projects/www/lists/netcat/archive/2014-01/message/284
Comment 1 David Strupl 2014-01-29 08:47:47 UTC
I think this is a P2 since it can make debugging the application unusable.
Comment 2 Jiri Kovalsky 2014-01-31 09:25:08 UTC
Agreed. Martine, can you please fix this one for 8.0? Thanks!
Comment 3 Martin Entlicher 2014-01-31 09:42:20 UTC
I've spent some time on this already and so far I do not see a way how to solve this. I will keep thinking about it...
Comment 4 Jiri Kovalsky 2014-02-04 13:44:35 UTC
Martine, any update on this problem? Thanks for your thoughts.
Comment 5 Martin Entlicher 2015-08-17 13:22:11 UTC
IMHO a reasonable solution would be to turn off "Track locations of component hierarchy changes" by default and have some indication directly in the Snapshot UI about the tracking of hierarchy changes, mentioning the possible slowness it will have on the application UI.
Comment 6 Jiri Kovalsky 2015-08-17 13:28:24 UTC
I agree. Let's turn it off and add some hint to the UI about performance impact if turned on.
Comment 7 Martin Entlicher 2015-08-21 15:46:54 UTC
Fixed by changeset:   291012:061b0b7e8563
http://hg.netbeans.org/core-main/rev/061b0b7e8563

The tracking of component hierarchy changes is turned off by default. A warning about performance impact is added. The setting can be easily turned on/off from the GUI snapshot's toolbar.
Comment 8 Quality Engineering 2015-08-23 01:22:50 UTC
Integrated into 'main-silver', will be available in build *201508230002* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)

Changeset: http://hg.netbeans.org/main-silver/rev/061b0b7e8563
User: mentlicher@netbeans.org
Log: #241082: Turn off tracking of component hierarchy changes by default. Added warning about perfomance impact when the user turns in on.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo