Bug 241071 - IllegalStateException: Different suspend counts! JPDA Thread = 1, thread instance of org.openide.util.RequestProcessor$Processor(name='Testing xRef /net/volvo/export/devarea/LLVM34/llvm/include/llvm/D
IllegalStateException: Different suspend counts! JPDA Thread = 1, thread inst...
Status: RESOLVED FIXED
Product: debugger
Classification: Unclassified
Component: Java
8.0
All All
: P2 (vote)
: Dev
Assigned To: Martin Entlicher
issues@debugger
EXCEPTIONS_REPORT
:
: 245689 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2014-01-28 15:55 UTC by Vladimir Voskresensky
Modified: 2016-10-20 01:58 UTC (History)
8 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
stacktrace (2.35 KB, text/plain)
2014-01-28 15:55 UTC, Vladimir Voskresensky
Details
stacktrace (1.80 KB, text/plain)
2015-10-05 09:21 UTC, Alexander Simon
Details
stacktrace (1.35 KB, text/plain)
2016-10-14 05:40 UTC, stefan79
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Vladimir Voskresensky 2014-01-28 15:55:24 UTC
Build: NetBeans IDE Dev (Build 20140128-895ff9405b13)
VM: Java HotSpot(TM) Server VM, 24.45-b08, Java(TM) SE Runtime Environment, 1.7.0_45-b18
OS: SunOS

User Comments:
vv159170: attaching debugger




Stacktrace: 
java.lang.IllegalStateException: Different suspend counts! JPDA Thread = 1, thread instance of org.openide.util.RequestProcessor$Processor(name='Testing xRef /net/volvo/export/devarea/LLVM34/llvm/include/llvm/DebugInfo.h', id=13) = 0, thread's state: Thread 'Testing xRef /net/volvo/export/devarea/LLVM34/llvm/include/llvm/DebugInfo.h': status = 4, is suspended = false, suspend count = 0, is at breakpoint = false
   at org.netbeans.modules.debugger.jpda.models.JPDAThreadImpl.notifyMethodInvoking(JPDAThreadImpl.java:1317)
   at org.netbeans.modules.debugger.jpda.JPDADebuggerImpl.invokeMethod(JPDADebuggerImpl.java:1072)
   at org.netbeans.modules.debugger.jpda.JPDADebuggerImpl.invokeMethod(JPDADebuggerImpl.java:1010)
   at org.netbeans.modules.debugger.jpda.models.AbstractObjectVariable.getToStringValue(AbstractObjectVariable.java:518)
   at org.netbeans.modules.debugger.jpda.models.AbstractObjectVariable.getToStringValue(AbstractObjectVariable.java:485)
   at org.netbeans.modules.debugger.jpda.models.AbstractObjectVariable.getToStringValue(AbstractObjectVariable.java:449)
Comment 1 Vladimir Voskresensky 2014-01-28 15:55:26 UTC
Created attachment 144479 [details]
stacktrace
Comment 2 Martin Entlicher 2014-07-22 15:39:21 UTC
*** Bug 245689 has been marked as a duplicate of this bug. ***
Comment 3 Exceptions Reporter 2015-07-06 18:28:51 UTC
This bug already has 10 duplicates 
see http://statistics.netbeans.org/exceptions/detail.do?id=186718
Comment 4 Alexander Simon 2015-10-05 09:21:57 UTC
Created attachment 156512 [details]
stacktrace

debug java application
Comment 5 stefan79 2016-10-14 05:40:30 UTC
Created attachment 162501 [details]
stacktrace

Exception occured while Remote-Debugging.
Comment 6 Exceptions Reporter 2016-10-14 05:40:35 UTC
This bug already has 20 duplicates 
see http://statistics.netbeans.org/exceptions/detail.do?id=186718
Comment 7 Martin Entlicher 2016-10-18 13:30:52 UTC
Unfortunately, it's almost impossible to guess what made the thread status differ.
The exception is information only and the mismatch is corrected afterwards, this is why log it only is sufficient IMHO:
changeset:   301558:dbb9d7c33b53
http://hg.netbeans.org/core-main/rev/dbb9d7c33b53
Comment 8 Quality Engineering 2016-10-20 01:58:25 UTC
Integrated into 'main-silver', will be available in build *201610200002* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)

Changeset: http://hg.netbeans.org/main-silver/rev/dbb9d7c33b53
User: mentlicher@netbeans.org
Log: #241071: Log the mismatch in the thread status only, instead of throwing an exception. The inconsistence is corrected afterwards.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo