Bug 241041 - UX problem: When usages results not clickable in a usefull way
UX problem: When usages results not clickable in a usefull way
Status: RESOLVED DUPLICATE of bug 240189
Product: editor
Classification: Unclassified
Component: Refactoring
8.0
PC Windows XP
: P3 (vote)
: TBD
Assigned To: Ralph Ruijs
issues@editor
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2014-01-28 07:33 UTC by kimsp
Modified: 2014-01-28 07:58 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments
IDE log (297.60 KB, text/plain)
2014-01-28 07:33 UTC, kimsp
Details

Note You need to log in before you can comment on or make changes to this bug.
Description kimsp 2014-01-28 07:33:43 UTC
Product Version = NetBeans IDE 8.0 Beta (Build 201401141042)
Operating System = Windows XP version 5.1 running on x86
Java; VM; Vendor = 1.7.0_45
Runtime = Java HotSpot(TM) Client VM 24.45-b08

If i seach for usages of some method and assumed I get som results then these are displayed in the Usages view. They are displayed in a tree structure, with project -> class -> line

If I click any of the classes found, the IDE opens that class. However, if I click the line node in the tree, then nothing happens unless I already have the class open (the class to which the line pertains).

I think it should go to the given line when I click it, no matter if I already have the class open or not.

Keep on rockin'

Best regards
Kim
Comment 1 kimsp 2014-01-28 07:33:49 UTC
Created attachment 144444 [details]
IDE log
Comment 2 Jaroslav Havlin 2014-01-28 07:58:11 UTC
Probably duplicate of bug 240189.
Thank you for reporting.

*** This bug has been marked as a duplicate of bug 240189 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo