Bug 241011 - Find Usages seems to be broken
Find Usages seems to be broken
Status: RESOLVED DUPLICATE of bug 240189
Product: java
Classification: Unclassified
Component: Refactoring
8.0
PC Windows 7
: P2 (vote)
: 8.0
Assigned To: Ralph Ruijs
issues@java
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2014-01-27 14:00 UTC by Maksim Khramov
Modified: 2014-02-04 09:38 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Maksim Khramov 2014-01-27 14:00:41 UTC
Product Version: NetBeans IDE Dev (Build 201401100002)
Java: 1.7.0_45; Java HotSpot(TM) 64-Bit Server VM 24.45-b06

Steps to reproduce:
Create java class with some field in it like:

public class JavaApplication9 {
    private static String helloWorld = "Hello World";
    /**
     * @param args the command line arguments
     */
    public static void main(String[] args) {
        System.out.println(helloWorld);
    }
    
}

invoke Find Usages command over helloWorld field. Opened Usages tab...
Click on line with System.out.println(helloWorld); code
IDE moves caret at this line.
Close file and click on same line again. No result. And IDE shows message: "The destination was not found" in status line

If now click on refresh button and than click on same line again IDE opens target file and highlights line properly
Comment 1 Maksim Khramov 2014-01-28 08:29:06 UTC
Reproduced with Build 201401100002 with all updates installed but not reproduced on fresh Build 201401280001
Comment 2 David Strupl 2014-02-04 09:11:19 UTC
Ralph, can you please have a look at this one? Thanks.
Comment 3 Ralph Ruijs 2014-02-04 09:38:29 UTC

*** This bug has been marked as a duplicate of bug 240189 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo