Bug 240977 - refactor error when lombok in the classpath
refactor error when lombok in the classpath
Status: RESOLVED DUPLICATE of bug 236885
Product: java
Classification: Unclassified
Component: Source
8.0
PC Linux
: P3 (vote)
: TBD
Assigned To: Svata Dedic
issues@java
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2014-01-26 15:31 UTC by makos
Modified: 2014-01-27 08:33 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description makos 2014-01-26 15:31:23 UTC
1. Create maven project
2. Add lombok to the dependencies
3. Create sample class with sample String field
4. Add lombok @Data annotation to the class
5. Try to rename this class using CTRL+R
6. As a result class is renamed but some rubbish characters are added to the class code 

The same in versions 7.4 and 8.0beta
Comment 1 Jiri Prox 2014-01-27 08:33:07 UTC

*** This bug has been marked as a duplicate of bug 236885 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo