Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 240506 - Choosing JDK 7 platform does not copy JavaFX RT jars to /dist/lib
Choosing JDK 7 platform does not copy JavaFX RT jars to /dist/lib
Status: RESOLVED DUPLICATE of bug 239388
Product: javafx
Classification: Unclassified
Component: Deployment
8.0
PC Windows 7
: P3 (vote)
: TBD
Assigned To: Roman Svitanic
issues@javafx
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2014-01-15 16:24 UTC by MackSix
Modified: 2014-01-15 16:32 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description MackSix 2014-01-15 16:24:13 UTC
If I have NetBeans running on JDK 8 and choose a JDK 7 platform for a JavaFX project, it will compile but won't run unless I add the folder  \Java\jdk1.7.0_45\jre\lib to the libraries. Without this the required JavaFX jars are not copied to the dist/lib/ directory. 

If NetBeans is running on JDK 7, I don't have to do this.


Product Version: NetBeans IDE Dev (Build 201401150002)
Java: 1.8.0-ea; Java HotSpot(TM) 64-Bit Server VM 25.0-b65
Runtime: Java(TM) SE Runtime Environment 1.8.0-ea-b123
System: Windows 7 version 6.1 running on amd64; Cp1252; en_US (nb)
Comment 1 Roman Svitanic 2014-01-15 16:32:11 UTC
jfxrt.jar should not be copied to dist/lib. But anyway, this is a duplicate.

*** This bug has been marked as a duplicate of bug 239388 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo