Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 240505 - Cannot run JavaFX application created in IDE on JDK8 but project platform is JDK7
Cannot run JavaFX application created in IDE on JDK8 but project platform is ...
Status: VERIFIED DUPLICATE of bug 239388
Product: javafx
Classification: Unclassified
Component: Deployment
8.0
PC Windows 7
: P2 (vote)
: TBD
Assigned To: Roman Svitanic
issues@javafx
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2014-01-15 16:14 UTC by Jiri Skrivanek
Modified: 2014-01-16 07:45 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments
Run log. (3.06 KB, text/plain)
2014-01-15 16:14 UTC, Jiri Skrivanek
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Jiri Skrivanek 2014-01-15 16:14:17 UTC
Created attachment 143994 [details]
Run log.

It is not possible to run JavaFX application where project platform is JDK7 but IDE runs with JDK8. To reproduce:

- run IDE with JDK8
- open new project wizard
- choose "JavaFX|JavaFX Application" and click Next
- click Manage Platforms and add JDK7 platform
- click Finish to create project
- run project but it fails (see log)

Product Version: NetBeans IDE Dev (Build 201401150002)
Java: 1.8.0-ea; Java HotSpot(TM) 64-Bit Server VM 25.0-b65
Runtime: Java(TM) SE Runtime Environment 1.8.0-ea-b123
System: Windows 7 version 6.1 running on amd64; Cp1250; en_US (nb)
Comment 1 Roman Svitanic 2014-01-15 16:25:56 UTC

*** This bug has been marked as a duplicate of bug 239388 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo