Bug 240189 - [regression] broken "Go To Source" in Find Usages tab
[regression] broken "Go To Source" in Find Usages tab
Status: VERIFIED FIXED
Product: editor
Classification: Unclassified
Component: Refactoring
8.0
PC Solaris
: P2 (vote)
: 8.0
Assigned To: Ralph Ruijs
issues@editor
cndreq
: REGRESSION
: 241011 241041 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2014-01-10 09:35 UTC by soldatov
Modified: 2014-02-04 09:38 UTC (History)
6 users (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description soldatov 2014-01-10 09:35:03 UTC
Scenario:
- Create Quote project
- Open cpu.cc
- Select ComputeSupportMetric at 37th line and call context menu
- Select Find Usages
- Press Find button
- click on second node (at disk.cc file)
==> "The destination was not found." message appears
Comment 1 Vladimir Voskresensky 2014-01-10 13:41:23 UTC
it's the regression caused by 
http://hg.netbeans.org/cnd-main/rev/6a7c71b2a794
getDocument always returns "null" for files not opened in editor.

editSupp.edit();
have to be called as before to force opening documents
Comment 2 Vladimir Voskresensky 2014-01-13 07:28:11 UTC
We have failed refactoring tests for a week.
Ralph, any news? 
Otherwise may be just backout your change caused regression?
Comment 3 Ralph Ruijs 2014-01-13 07:32:34 UTC
(In reply to Vladimir Voskresensky from comment #2)
> We have failed refactoring tests for a week.

Issue is only 3 days old, of which 2 are during the weekend.

> Ralph, any news? 
> Otherwise may be just backout your change caused regression?

I'm looking at it.
Comment 4 Vladimir Voskresensky 2014-01-13 07:54:13 UTC
Thanks for you attention!
(Couldn't file earlier, had state holidays)
Comment 5 Ralph Ruijs 2014-01-13 08:14:02 UTC
changeset   : 792a3b772925
author      : Ralph Benjamin Ruijs <ralphbenjamin@netbeans.org>
date        : Mon Jan 13 09:07:22 CET 2014
summary     : #240189 - broken "Go To Source" in Find Usages tab
Comment 6 Vladimir Voskresensky 2014-01-14 10:16:10 UTC
Ralph, thank you so much!
Comment 7 Vladimir Voskresensky 2014-01-14 10:16:45 UTC
Btw, shouldn't it be integrated into Beta?
Comment 8 Ralph Ruijs 2014-01-14 10:25:51 UTC
(In reply to Vladimir Voskresensky from comment #7)
> Btw, shouldn't it be integrated into Beta?

I do not think it is a stopper for beta, but added David and Jirka to CC, just to be sure.
Comment 9 Vladimir Voskresensky 2014-01-14 10:32:29 UTC
To summarize user visible impact:
- any element in Find Usages results window can not be opened by any way (neither dbl click nor Go To popup menu action) if corresponding editor was not opened before by user explicitly
Comment 10 Jaroslav Havlin 2014-01-28 07:58:11 UTC
*** Bug 241041 has been marked as a duplicate of this bug. ***
Comment 11 Ralph Ruijs 2014-02-04 09:38:29 UTC
*** Bug 241011 has been marked as a duplicate of this bug. ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo