Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 240105 - [80cat] Umbrella: JavaFX issues when IDE runs on JDK 8 but project set to compile for JDK 7
[80cat] Umbrella: JavaFX issues when IDE runs on JDK 8 but project set to com...
Status: RESOLVED FIXED
Product: javafx
Classification: Unclassified
Component: Project
8.0
PC All
: P3 (vote)
: TBD
Assigned To: Roman Svitanic
issues@javafx
: UMBRELLA
: 254724 (view as bug list)
Depends on:
Blocks: 239388 239673 239996 240052 240097
  Show dependency treegraph
 
Reported: 2014-01-08 08:34 UTC by Lou Dasaro
Modified: 2016-02-12 05:29 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Lou Dasaro 2014-01-08 08:34:28 UTC
This is the umbrella for a variety of issues that arise when NetBeans 8 is running on JDK 8 but compilation is set to JDK 7 in Project Properties. If I am in error in working this issue in the manner, my apologies. Please correct me.

It is likely that these issues have a similar root cause, hence the umbrella. 
The stopgap/workaround is for the user to install NetBeans on JDK 7 *if* their intention is to compile for both JDK 7 and 8. My opinion is that this is a valid workaround for the moment, while Java 8 is still early access, but the root cause should still be addressed in a patch or point release if it cannot be addressed in time for NetBeans 8.0 FCS.
Comment 1 Lou Dasaro 2014-01-08 08:42:25 UTC

*** This bug has been marked as a duplicate of bug 239388 ***
Comment 2 Lou Dasaro 2014-01-08 09:02:49 UTC
Changed from duplicated to blocker and reopened.
Comment 3 Lou Dasaro 2015-10-09 19:14:09 UTC
Remains an issue for NetBeans 8.1. See https://netbeans.org/community/releases/81/relnotes.html#known_issues

However, this and related scenarios/workarounds become unnecessary in JDK 9 branch builds, where one can build JavaFX projects for JDK 7, 8 or 9 targets without changing the JDK to start the IDE.

Therefore, I am marking this Fixed because the related Bugs have effectively been Fixed and Verified using JDK 9 branch build.
Product Version: NetBeans Dev JDK9 branch (Build 201506180405)
Java: 1.9.0-ea; Java HotSpot(TM) Client VM 1.9.0-ea-b82
Runtime: Java(TM) SE Runtime Environment 1.9.0-ea-b82
System: Windows 8.1 version 6.3 running on x86; Cp1252; en_US (nb)
Comment 4 Lou Dasaro 2016-02-12 05:29:03 UTC
*** Bug 254724 has been marked as a duplicate of this bug. ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo