Bug 240039 - Double "Unit tests" folders in New file dialog
Double "Unit tests" folders in New file dialog
Status: RESOLVED FIXED
Product: java
Classification: Unclassified
Component: JUnit
8.0
Macintosh Mac OS X
: P3 (vote)
: 8.0
Assigned To: Theofanis Oikonomou
junit-issues@java
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2014-01-06 19:30 UTC by kimsp
Modified: 2014-01-08 02:51 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments
new file dialog (221.08 KB, image/tiff)
2014-01-06 19:31 UTC, kimsp
Details

Note You need to log in before you can comment on or make changes to this bug.
Description kimsp 2014-01-06 19:30:02 UTC
[ BUILD # : 201312230002 ]
[ JDK VERSION : 1.7.0_45 ]

STEPS:
   * Open a Java project or a Maven project
   * Open New File dialog
   * Open New File dialog

ACTUAL:
   * In the Categories part of the dialog there are two folders named "Unit
tests". One with Java unit tests (junit etc) and one for web (grunt)

EXPECTED:
   two folders, e.g. one named web unit tests and one named unit tests (or
maybe: unit tests (java) and unit test (web).

The current way adds confusion
Comment 1 kimsp 2014-01-06 19:31:07 UTC
Please disregard one of the "Open New file Dialog" items below. Too fast with copy paste.
Comment 2 kimsp 2014-01-06 19:31:27 UTC
Created attachment 143640 [details]
new file dialog
Comment 3 Theofanis Oikonomou 2014-01-07 15:08:28 UTC
The problem is that there is no category set for the Karma Configuration File template. In a j2se project the second Unit Tests category should not even be visible to the user. Will fix asap. Thank you for reporting.
Comment 4 Theofanis Oikonomou 2014-01-07 15:11:40 UTC
Changeset: cbc5ff041481
Author:    Theofanis Oikonomou <theofanis@netbeans.org>
Date:      2014-01-07 16:12
Message:
Comment 5 Quality Engineering 2014-01-08 02:51:42 UTC
Integrated into 'main-silver', will be available in build *201401080002* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)

Changeset: http://hg.netbeans.org/main-silver/rev/cbc5ff041481
User: Theofanis Oikonomou <theofanis@netbeans.org>
Log: Task #240039 - Double "Unit tests" folders in New file dialog


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo