Bug 239881 - javascript's const keyword not recognized as a valid statement
javascript's const keyword not recognized as a valid statement
Status: RESOLVED DUPLICATE of bug 226477
Product: javascript
Classification: Unclassified
Component: Editor
7.4
PC Windows 8
: P3 (vote)
: TBD
Assigned To: Petr Pisl
issues@javascript
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2013-12-30 23:15 UTC by rednael
Modified: 2014-01-02 07:03 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments
IDE log (35.48 KB, text/plain)
2013-12-30 23:15 UTC, rednael
Details

Note You need to log in before you can comment on or make changes to this bug.
Description rednael 2013-12-30 23:15:32 UTC
Product Version = NetBeans IDE 7.4 (Build 201310111528)
Operating System = Windows 8 version 6.2 running on x86
Java; VM; Vendor = 1.7.0_45
Runtime = Java HotSpot(TM) Client VM 24.45-b08

The const keyword of javascript does not seem to be supported by the Editor, as it gives the error "Expected an operand but found const".
Const has been around for quiet some time. Since javascript 1.5.
Please see the javascript reference for more information: https://developer.mozilla.org/en-US/docs/Web/JavaScript/Reference/Statements/const
Comment 1 rednael 2013-12-30 23:15:36 UTC
Created attachment 143527 [details]
IDE log
Comment 2 Vladimir Riha 2014-01-02 07:03:55 UTC

*** This bug has been marked as a duplicate of bug 226477 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo