Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 239360 - OutOfMemoryError: Many instances of HighlightItem
OutOfMemoryError: Many instances of HighlightItem
Status: RESOLVED FIXED
Product: editor
Classification: Unclassified
Component: Painting & Printing
7.4
All All
: P1 with 1 vote (vote)
: 8.1
Assigned To: Miloslav Metelka
issues@editor
EXCEPTIONS_REPORT
:
: 229402 239460 240601 241090 241654 244652 245258 247809 249419 251456 254404 256466 256597 (view as bug list)
Depends on: 254701 254926 254932 255062
Blocks:
  Show dependency treegraph
 
Reported: 2013-12-11 12:40 UTC by ozziej
Modified: 2015-11-16 10:53 UTC (History)
12 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
stacktrace (601 bytes, text/plain)
2013-12-11 12:40 UTC, ozziej
Details

Note You need to log in before you can comment on or make changes to this bug.
Description ozziej 2013-12-11 12:40:02 UTC
This issue was reported manually by obrejla.
It already has 1 duplicates 


Build: NetBeans IDE 7.4 Beta (Build 201307092200)
VM: Java HotSpot(TM) 64-Bit Server VM, 23.21-b01, Java(TM) SE Runtime Environment, 1.7.0_21-b12
OS: Mac OS X

User Comments:
ozziej: Do a global search, find replace.




Stacktrace: 
java.lang.OutOfMemoryError: GC overhead limit exceeded
   at java.lang.String.valueOf(String.java:2868)
   at java.lang.Thread.getName(Thread.java:1148)
   at java.lang.management.ThreadInfo.initialize(ThreadInfo.java:223)
   at java.lang.management.ThreadInfo.<init>(ThreadInfo.java:195)
   at sun.management.ThreadImpl.dumpThreads0(ThreadImpl.java:0)
   at sun.management.ThreadImpl.dumpAllThreads(ThreadImpl.java:446)
Comment 1 ozziej 2013-12-11 12:40:03 UTC
Created attachment 143053 [details]
stacktrace
Comment 2 Jaroslav Havlin 2013-12-12 13:02:26 UTC
There are about 2 million instances of o.n.m.editor.lib2.highlighting.HighlightItem.
Retained size of all instances of o.n.m.editor.lib2.view.ParagraphView is 464 MB.

Reassigning to editor/Painting & Printing. Please evaluate it, thank you.
Comment 3 Jaroslav Havlin 2013-12-13 15:26:25 UTC
*** Bug 239460 has been marked as a duplicate of this bug. ***
Comment 4 Jaroslav Havlin 2014-01-17 13:12:36 UTC
*** Bug 240601 has been marked as a duplicate of this bug. ***
Comment 5 Exceptions Reporter 2014-01-24 12:43:02 UTC
This bug already has 5 duplicates 
see http://statistics.netbeans.org/exceptions/detail.do?id=205934
Comment 6 Jaroslav Havlin 2014-01-29 11:59:58 UTC
*** Bug 241090 has been marked as a duplicate of this bug. ***
Comment 7 Jaroslav Havlin 2014-02-11 10:13:42 UTC
*** Bug 241654 has been marked as a duplicate of this bug. ***
Comment 8 Jaroslav Havlin 2014-05-23 08:48:29 UTC
*** Bug 244652 has been marked as a duplicate of this bug. ***
Comment 9 Jaroslav Havlin 2014-07-07 11:10:39 UTC
*** Bug 245258 has been marked as a duplicate of this bug. ***
Comment 10 Jaroslav Havlin 2014-10-13 11:27:49 UTC
*** Bug 247809 has been marked as a duplicate of this bug. ***
Comment 11 Exceptions Reporter 2014-12-07 12:16:23 UTC
This bug already has 50 duplicates 
see http://statistics.netbeans.org/exceptions/detail.do?id=205934
Comment 12 Dusan Balek 2015-03-05 14:31:29 UTC
*** Bug 249419 has been marked as a duplicate of this bug. ***
Comment 13 Jaroslav Havlin 2015-08-14 09:27:44 UTC
*** Bug 251456 has been marked as a duplicate of this bug. ***
Comment 14 Miloslav Metelka 2015-09-02 08:56:39 UTC
There are several distinct leak types so adding them as dependent issues and resolving them one by one.
Comment 15 Miloslav Metelka 2015-09-07 14:55:32 UTC
There should be no more leak types besides the four dependent problems that I've already fixed so marking the issue as fixed.
Comment 16 Miloslav Metelka 2015-09-07 15:24:04 UTC
*** Bug 229402 has been marked as a duplicate of this bug. ***
Comment 17 Miloslav Metelka 2015-11-10 12:48:49 UTC
*** Bug 256466 has been marked as a duplicate of this bug. ***
Comment 18 Miloslav Metelka 2015-11-12 08:46:50 UTC
*** Bug 254404 has been marked as a duplicate of this bug. ***
Comment 19 Miloslav Metelka 2015-11-16 10:53:42 UTC
*** Bug 256597 has been marked as a duplicate of this bug. ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo